app-misc/elasticsearch: bump to 5.6.4
authorTomas Mozes <hydrapolic@gmail.com>
Thu, 16 Nov 2017 13:51:49 +0000 (14:51 +0100)
committerAmy Liffey <amynka@gentoo.org>
Thu, 16 Nov 2017 16:03:19 +0000 (17:03 +0100)
Package-Manager: Portage-2.3.14, Repoman-2.3.6

app-misc/elasticsearch/Manifest
app-misc/elasticsearch/elasticsearch-5.6.4.ebuild [new file with mode: 0644]

index 19d9a7daebad5785f7640e7127bcfde5575f9256..908d117f335004aee8aa736dec9ac8b8c75b3f4f 100644 (file)
@@ -1,2 +1,3 @@
 DIST elasticsearch-5.5.2.tar.gz 33485703 SHA256 0870e2c0c72e6eda976effa07aa1cdd06a9500302320b5c22ed292ce21665bf1 SHA512 62048f15b43e38a61e3a19a1599c25cd0d9009cc1172db5b450b04dec349ecd313b1f20e3d1c7ed1c101ae3e6f6c6d2cdf004a9713ad803576277f93e3adbdb9 WHIRLPOOL 3a71cef2858b76b11e1693907e745912a83f23e26c35a3456c6324fc19c317c53d4404e20134b034e41e162c1ea8d58c38bbd4afe0394d886ab32f6b698172ec
 DIST elasticsearch-5.6.3.tar.gz 33774486 SHA256 492b7e59d5204b3dc7eb13b611c33b3db36b392bdd6a4c004ba99c6543fc28f9 SHA512 ee57d010e196eb25e5296fe95ab2de5e503d4d66f7eec8c8f6ac2ff9ddbc1a8dc1514202d705e291ee49d3e04650b597a9afc5f92f179b8faa5e2fe3c662f33e WHIRLPOOL bda081e6b91d1076a39e0af75b44d7f877f28178281de1f22c5177abf804c9395dacabb3c93ec93aff65223df42353bc955bbf60e74fb07f99320096dd97173a
+DIST elasticsearch-5.6.4.tar.gz 33776770 SHA256 1098fc776fae8c74e65f8e17cf2ea244c1d07c4e6711340c9bb9f6df56aa45b0 SHA512 37730f39cf1711b6a20861370ef7aff4b48e7f90ad82cb1c8c92643179194c4dcdf0180691d8065304bf61e7f5a2fb1ed5c84c384e0b2ff7ad0dc58ac7352f47 WHIRLPOOL 37f1a615a7916738bb8f4809213edced96aaecf3d93df8cad0bc175c71191a6f1d3d616fc40b71e647b65e4c2e03f4f6ab9a4ff333b55d3728ca100b2181edbc
diff --git a/app-misc/elasticsearch/elasticsearch-5.6.4.ebuild b/app-misc/elasticsearch/elasticsearch-5.6.4.ebuild
new file mode 100644 (file)
index 0000000..cd91e97
--- /dev/null
@@ -0,0 +1,69 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit systemd user
+
+DESCRIPTION="Open Source, Distributed, RESTful, Search Engine"
+HOMEPAGE="https://www.elastic.co/products/elasticsearch"
+SRC_URI="https://artifacts.elastic.co/downloads/${PN}/${P}.tar.gz"
+LICENSE="Apache-2.0 BSD-2 LGPL-3 MIT public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="virtual/jre:1.8"
+
+pkg_setup() {
+       enewgroup ${PN}
+       enewuser ${PN} -1 /bin/bash /usr/share/${PN} ${PN}
+}
+
+src_prepare() {
+       rm -v bin/*.{bat,exe} LICENSE.txt || die
+
+       default
+}
+
+src_install() {
+       keepdir /etc/${PN}
+       keepdir /etc/${PN}/scripts
+
+       insinto /etc/${PN}
+       doins config/*
+       rm -rv config || die
+
+       insinto /usr/share/${PN}
+       doins -r ./*
+
+       exeinto /usr/share/${PN}/bin
+       doexe "${FILESDIR}/elasticsearch-systemd-pre-exec"
+
+       chmod +x "${ED}"/usr/share/${PN}/bin/* || die
+
+       keepdir /var/{lib,log}/${PN}
+       fowners ${PN}:${PN} /var/{lib,log}/${PN}
+       fperms 0750 /var/{lib,log}/${PN}
+       dodir /usr/share/${PN}/plugins
+
+       insinto /etc/sysctl.d
+       newins "${FILESDIR}/${PN}.sysctl.d" ${PN}.conf
+
+       newconfd "${FILESDIR}/${PN}.conf.2" ${PN}
+       newinitd "${FILESDIR}/${PN}.init.2" ${PN}
+
+       systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles.d" ${PN}.conf
+       systemd_newunit "${FILESDIR}"/${PN}.service ${PN}.service
+}
+
+pkg_postinst() {
+       elog
+       elog "You may create multiple instances of ${PN} by"
+       elog "symlinking the init script:"
+       elog "ln -sf /etc/init.d/${PN} /etc/init.d/${PN}.instance"
+       elog
+       elog "Please make sure you put elasticsearch.yml, log4j2.properties and scripts"
+       elog "from /etc/elasticsearch into the configuration directory of the instance:"
+       elog "/etc/${PN}/instance"
+       elog
+}