media-video/openshot: version bump to 2.5.1
authorStefan Strogin <steils@gentoo.org>
Sat, 16 May 2020 02:40:42 +0000 (05:40 +0300)
committerStefan Strogin <steils@gentoo.org>
Sat, 16 May 2020 02:42:49 +0000 (05:42 +0300)
- Add python3_8 to PYTHON_COMPAT.
- Fix sub-slotting for media-libs/libopenshot.

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Stefan Strogin <steils@gentoo.org>
media-video/openshot/Manifest
media-video/openshot/openshot-2.5.1.ebuild [new file with mode: 0644]

index 89dc235782655352d9e676382e5f378bf65347bf..f1f9d20dc9b54a222628b42fcb213a43b4ca85f3 100644 (file)
@@ -1,3 +1,4 @@
 DIST openshot-2.4.4.tar.gz 63065376 BLAKE2B 2ee00f24d699d5935a182c394821f215a27ba2701d493f51299c19cf99452ca4df2e5b86f7a6e5734e6194e39e5b7995eb94be168c0e9f7bc7a3b78206277304 SHA512 efa71f97a83b89e691b7dab09288ba7d3e91eb25119669fa8f6e28becb8d4cb3e60a923f936ee4ff9a593d016fe3a6b0348153cff937ab7d21a5517de5dfa10c
 DIST openshot-2.5.0.tar.gz 60153193 BLAKE2B cdc79c68be7cd5b9e2714c98c4edbb5fc9ec349283da8439e9f9e26b2341688e2b8ae0f108413f59582d6e447faeb96d1da6916503299ca40939d73f5983377f SHA512 0944bff48c8957a4a3c5a37428b4d3e45e8ad6e1664812ea90b7c16d014a3c355daf2fe183ce855586114ccfa36c419b6baacc42c4bf871de29bda4c24f2a814
+DIST openshot-2.5.1.tar.gz 60217543 BLAKE2B 3f195b14a9fb004e845c731be64138c20da84ac0c90db43b547ee9ea059d32f85ada04aa0462b755a7ea5c3d3b30088fab35414147dded55deb9d5eab5926d2d SHA512 8254a45254bbe523b6485b9598022de2c46ec30818e606ac4665790d29486693c4efe9f5bc55ee43d6342de6782cf0090e4bc880e831c08e3b1218bca555af14
 DIST openshot-qt-2.4.0.tar.gz 60710408 BLAKE2B 33c8abe7ba3122ae720163d6ab91d367ee282b94d3d8986fdccf4f9efae832f54af7f946472c781a17f7e54083028762952d02d7139e6815cd0d44e80515c728 SHA512 95778effa5b02a467c44741384b0f43bf90343d4f450d5fcc2319ff1c3bee212338435dd8c781e0ff111a704aacdce3dbfb6bdcf62afa1f59bbb0668b58074ca
diff --git a/media-video/openshot/openshot-2.5.1.ebuild b/media-video/openshot/openshot-2.5.1.ebuild
new file mode 100644 (file)
index 0000000..20bc674
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE=xml
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1 xdg
+
+MY_PN="${PN}-qt"
+
+DESCRIPTION="An award-winning free and open-source video editor"
+HOMEPAGE="https://www.openshot.org/"
+SRC_URI="https://github.com/OpenShot/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="1"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+       $(python_gen_cond_dep '
+               dev-python/httplib2[${PYTHON_MULTI_USEDEP}]
+               dev-python/PyQt5[${PYTHON_MULTI_USEDEP},gui,svg,webkit,widgets]
+               dev-python/pyzmq[${PYTHON_MULTI_USEDEP}]
+               dev-python/requests[${PYTHON_MULTI_USEDEP}]
+       ')
+       >=media-libs/libopenshot-0.2.5:0=[python,${PYTHON_SINGLE_USEDEP}]
+"
+BDEPEND="
+       $(python_gen_cond_dep '
+               doc? ( dev-python/sphinx[${PYTHON_MULTI_USEDEP}] )
+       ')
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_prepare() {
+       distutils-r1_python_prepare_all
+       # prevent setup.py from trying to update MIME databases
+       sed -i 's/^ROOT =.*/ROOT = False/' setup.py || die
+}
+
+python_compile_all() {
+       use doc && emake -C doc html
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( doc/_build/html/. )
+       distutils-r1_python_install_all
+}