dev-python/sphinx_selective_exclude: initial import
authorAndrey Grozin <grozin@gentoo.org>
Sun, 8 Mar 2020 11:50:20 +0000 (18:50 +0700)
committerAndrey Grozin <grozin@gentoo.org>
Sun, 8 Mar 2020 11:50:20 +0000 (18:50 +0700)
Package-Manager: Portage-2.3.92, Repoman-2.3.20
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
dev-python/sphinx_selective_exclude/Manifest [new file with mode: 0644]
dev-python/sphinx_selective_exclude/metadata.xml [new file with mode: 0644]
dev-python/sphinx_selective_exclude/sphinx_selective_exclude-1.0.3.ebuild [new file with mode: 0644]

diff --git a/dev-python/sphinx_selective_exclude/Manifest b/dev-python/sphinx_selective_exclude/Manifest
new file mode 100644 (file)
index 0000000..a3bbbcf
--- /dev/null
@@ -0,0 +1 @@
+DIST sphinx_selective_exclude-1.0.3.tar.gz 7227 BLAKE2B 90ba94f81e6dfc00a39bbcaf50d136c01c7b756bcb9366ab111169913fb2a571b7924afc89fd8fffc9cf7c96bc64cd2737441bd5228fe22f9e5a9687b5b4ae52 SHA512 8ceace1502948caa17bf611786132720093b818039b399eb832c12dc47ad86219610495698692c2c25a98a8ede8695a66b02f5e3bb6ea2c7d2410e275cd959f9
diff --git a/dev-python/sphinx_selective_exclude/metadata.xml b/dev-python/sphinx_selective_exclude/metadata.xml
new file mode 100644 (file)
index 0000000..b403fcb
--- /dev/null
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="person">
+    <email>grozin@gentoo.org</email>
+    <name>Andrey Grozin</name>
+  </maintainer>
+  <maintainer type="project">
+    <email>python@gentoo.org</email>
+    <name>Python</name>
+  </maintainer>
+  <upstream>
+    <remote-id type="pypi">sphinx_selective_exclude</remote-id>
+    <remote-id type="github">pfalcon/sphinx_selective_exclude</remote-id>
+  </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinx_selective_exclude/sphinx_selective_exclude-1.0.3.ebuild b/dev-python/sphinx_selective_exclude/sphinx_selective_exclude-1.0.3.ebuild
new file mode 100644 (file)
index 0000000..6fa37df
--- /dev/null
@@ -0,0 +1,19 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx selective rendition extensions"
+HOMEPAGE="https://github.com/pfalcon/sphinx_selective_exclude"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+PDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"