app-emulation/qemu: Reintroduce USE="static-user"
authorMatthias Maier <tamiko@gentoo.org>
Tue, 28 Feb 2017 05:44:38 +0000 (23:44 -0600)
committerMatthias Maier <tamiko@gentoo.org>
Tue, 28 Feb 2017 05:44:38 +0000 (23:44 -0600)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

app-emulation/qemu/qemu-2.8.0-r6.ebuild [moved from app-emulation/qemu/qemu-2.8.0-r5.ebuild with 98% similarity]

similarity index 98%
rename from app-emulation/qemu/qemu-2.8.0-r5.ebuild
rename to app-emulation/qemu/qemu-2.8.0-r6.ebuild
index d4a03a7f1c446bf5b9c326a075fceddef0cb72e8..e1c6b9ba0128c88d0a72587edaf36002d4092dbb 100644 (file)
@@ -29,8 +29,8 @@ IUSE="accessibility +aio alsa bluetooth bzip2 +caps +curl debug +fdt
        glusterfs gnutls gtk gtk2 infiniband iscsi +jpeg kernel_linux
        kernel_FreeBSD lzo ncurses nfs nls numa opengl +pin-upstream-blobs +png
        pulseaudio python rbd sasl +seccomp sdl sdl2 selinux smartcard snappy
-       spice ssh static systemtap tci test +threads usb usbredir vde
-       +vhost-net virgl virtfs +vnc vte xattr xen xfs"
+       spice ssh static static-user systemtap tci test +threads usb usbredir
+       vde +vhost-net virgl virtfs +vnc vte xattr xen xfs"
 
 COMMON_TARGETS="aarch64 alpha arm cris i386 m68k microblaze microblazeel
        mips mips64 mips64el mipsel or32 ppc ppc64 s390x sh4 sh4eb sparc
@@ -53,7 +53,7 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}
        qemu_softmmu_targets_ppc? ( fdt )
        qemu_softmmu_targets_ppc64? ( fdt )
        sdl2? ( sdl )
-       static? ( !alsa !pulseaudio !bluetooth !opengl !gtk !gtk2 )
+       static? ( static-user !alsa !bluetooth !gtk !gtk2 !opengl !pulseaudio )
        virtfs? ( xattr )
        vte? ( gtk )"
 
@@ -174,6 +174,7 @@ DEPEND="${CDEPEND}
        kernel_linux? ( >=sys-kernel/linux-headers-2.6.35 )
        gtk? ( nls? ( sys-devel/gettext ) )
        static? ( ${TARGETS_DEPEND} )
+       static-user? ( ${TARGETS_DEPEND} )
        test? (
                dev-libs/glib[utils]
                sys-devel/bc
@@ -469,6 +470,7 @@ qemu_src_configure() {
                        --disable-blobs
                        --disable-tools
                )
+               local static_flag="static-user"
                ;;
        softmmu)
                # audio options
@@ -486,6 +488,7 @@ qemu_src_configure() {
                )
                use gtk && conf_opts+=( --with-gtkabi=$(usex gtk2 2.0 3.0) )
                use sdl && conf_opts+=( --with-sdlabi=$(usex sdl2 2.0 1.2) )
+               local static_flag="static"
                ;;
        tools)
                conf_opts+=(
@@ -495,6 +498,7 @@ qemu_src_configure() {
                        --enable-tools
                        $(use_enable bzip2)
                )
+               local static_flag="static"
                ;;
        esac
 
@@ -507,7 +511,7 @@ qemu_src_configure() {
        # We always want to attempt to build with PIE support as it results
        # in a more secure binary. But it doesn't work with static or if
        # the current GCC doesn't have PIE support.
-       if use static; then
+       if use ${static_flag}; then
                conf_opts+=( --static --disable-pie )
        else
                gcc-specs-pie && conf_opts+=( --enable-pie )