net-misc/eventd: remove non-buildable broken versions
authorJoonas Niilola <juippis@gentoo.org>
Wed, 23 Oct 2019 04:34:41 +0000 (07:34 +0300)
committerJoonas Niilola <juippis@gentoo.org>
Wed, 23 Oct 2019 04:34:41 +0000 (07:34 +0300)
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
net-misc/eventd/Manifest
net-misc/eventd/eventd-0.21.0.ebuild [deleted file]
net-misc/eventd/eventd-0.24.1.ebuild [deleted file]

index eeb8ce809b98a426f177fcc9e18f925cfbe83dc6..f2c37465e8c6a675f520e2dbc34f905675d9ebf7 100644 (file)
@@ -1,3 +1 @@
-DIST eventd-0.21.0.tar.xz 392080 BLAKE2B 14d01d46e07e650f392abca53716c1fd5a5d70f05fe006e8a230d38be610e36ee0369742d258b46697376317be4ff6a071166a45528ef2840159a1024057d6cc SHA512 5907d453c493c9f2332df506037027ef7df021b1e29a6773cf8bb5c32c7a301b65ca55d3e3ea40982d3e48b837738c97b5420309a45a550f409d8912636d1dae
-DIST eventd-0.24.1.tar.xz 184276 BLAKE2B cd14506d7f539bd6076540c713c7957d52db1fb3a4a09ad52d2b1d4ab4b3d3c31c8245063a85efcef1abbc127fa534c15db1b297f9f651ac113b3723842f76f2 SHA512 c99a42364796cf7421bbb3c8b0d0810e1933b226c8bc4f74240d276d40bd9b96aae5d6016b8da92435222572fd1bf04441a63039f14162702f87aa0bdd4d67ed
 DIST eventd-0.27.0.tar.xz 188000 BLAKE2B 06779168e9049714aabc051f8a85a5e5764509c3deceddd300c103f4831b6679f082748858bebb9629dcd47fa0b570158c6cf2b665167ab8e20a7dc0f12cc00f SHA512 586fdf36742cfda5a3c5e4cf4600307b8d699701fdf32eec25a7b294c815ded6e7e41210e65c706c34c5f2d911cadec89b677f082dad183f486fb7d1a55a2302
diff --git a/net-misc/eventd/eventd-0.21.0.ebuild b/net-misc/eventd/eventd-0.21.0.ebuild
deleted file mode 100644 (file)
index e367b62..0000000
+++ /dev/null
@@ -1,120 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit linux-info systemd xdg-utils
-
-DESCRIPTION="A small daemon to act on remote or local events"
-HOMEPAGE="https://www.eventd.org/"
-SRC_URI="https://www.eventd.org/download/${PN}/${P}.tar.xz"
-
-LICENSE="GPL-3+ LGPL-3+ MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="debug fbcon +introspection ipv6 libcanberra libnotify +notification
-       pulseaudio purple speech systemd test upnp websocket +X zeroconf"
-
-REQUIRED_USE="
-       X? ( notification )
-       fbcon? ( notification )
-       notification? ( || ( X fbcon ) )
-"
-
-COMMON_DEPEND="
-       >=dev-libs/glib-2.40:2
-       sys-apps/util-linux
-       introspection? ( >=dev-libs/gobject-introspection-1.42 )
-       libcanberra? ( media-libs/libcanberra )
-       libnotify? ( x11-libs/gdk-pixbuf:2 )
-       notification? (
-               x11-libs/cairo
-               x11-libs/pango
-               x11-libs/gdk-pixbuf:2
-               X? (
-                       x11-libs/cairo[xcb]
-                       x11-libs/libxcb:=
-                       x11-libs/xcb-util
-                       x11-libs/xcb-util-wm
-               )
-       )
-       pulseaudio? (
-               media-libs/libsndfile
-               media-sound/pulseaudio
-       )
-       purple? ( net-im/pidgin )
-       speech? ( app-accessibility/speech-dispatcher )
-       systemd? ( sys-apps/systemd:= )
-       upnp? ( net-libs/gssdp:= )
-       websocket? ( >=net-libs/libsoup-2.50:2.4 )
-       zeroconf? ( net-dns/avahi[dbus] )
-"
-DEPEND="${COMMON_DEPEND}
-       app-text/docbook-xml-dtd:4.5
-       app-text/docbook-xsl-stylesheets
-       dev-libs/libxslt
-       virtual/pkgconfig
-       fbcon? ( virtual/os-headers )
-"
-RDEPEND="${COMMON_DEPEND}
-       net-libs/glib-networking[ssl]
-"
-
-pkg_setup() {
-       if use ipv6; then
-               CONFIG_CHECK=$(usex test 'IPV6' '~IPV6')
-               linux-info_pkg_setup
-       fi
-}
-
-src_prepare() {
-       default_src_prepare
-
-       # Workaround Gentoo bug 604398.
-       sed -i \
-               -e 's|libspeechd|speech-dispatcher/libspeechd|g' \
-               plugins/tts/src/tts.c || die
-
-       # Prevent access violations from introspection metadata generation.
-       xdg_environment_reset
-}
-
-src_configure() {
-       local myeconfargs=(
-               --with-systemduserunitdir="$(systemd_get_userunitdir)"
-               --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
-               --with-dbussessionservicedir="${EPREFIX}/usr/share/dbus-1/services"
-               $(use_enable websocket)
-               $(use_enable zeroconf dns-sd)
-               $(use_enable upnp ssdp)
-               $(use_enable introspection)
-               $(use_enable ipv6)
-               $(use_enable systemd)
-               $(use_enable notification notification-daemon)
-               # Wayland plugin requires wayland-wall, which is currently WIP.
-               # See https://github.com/wayland-wall/wayland-wall/issues/1
-               --disable-nd-wayland
-               $(use_enable X nd-xcb)
-               $(use_enable fbcon nd-fbdev)
-               $(use_enable purple im)
-               $(use_enable pulseaudio sound)
-               $(use_enable speech tts)
-               $(use_enable libnotify)
-               $(use_enable libcanberra)
-               $(use_enable debug)
-       )
-       econf "${myeconfargs[@]}"
-}
-
-src_test() {
-       local -x EVENTD_TESTS_TMP_DIR="${T}"
-       default_src_test
-}
-
-pkg_postinst() {
-       if { use notification || use libnotify; } && ! has_version 'gnome-base/librsvg'; then
-               elog
-               elog "For SVG icons in notifications, please install 'gnome-base/librsvg'."
-               elog
-       fi
-}
diff --git a/net-misc/eventd/eventd-0.24.1.ebuild b/net-misc/eventd/eventd-0.24.1.ebuild
deleted file mode 100644 (file)
index b981faf..0000000
+++ /dev/null
@@ -1,123 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit linux-info meson systemd xdg-utils
-
-DESCRIPTION="A small daemon to act on remote or local events"
-HOMEPAGE="https://www.eventd.org/"
-SRC_URI="https://www.eventd.org/download/eventd/${P}.tar.xz"
-
-LICENSE="GPL-3+ LGPL-3+ MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="debug fbcon +introspection ipv6 libcanberra libnotify +notification
-       pulseaudio purple speech systemd test upnp webhook websocket +X zeroconf"
-
-REQUIRED_USE="
-       X? ( notification )
-       fbcon? ( notification )
-       notification? ( || ( X fbcon ) )
-       test? ( websocket )
-"
-
-COMMON_DEPEND="
-       >=dev-libs/glib-2.40:2
-       sys-apps/util-linux
-       x11-libs/libxkbcommon
-       introspection? ( >=dev-libs/gobject-introspection-1.42 )
-       libcanberra? ( media-libs/libcanberra )
-       libnotify? ( x11-libs/gdk-pixbuf:2 )
-       notification? (
-               x11-libs/cairo
-               x11-libs/pango
-               x11-libs/gdk-pixbuf:2
-               X? (
-                       x11-libs/cairo[xcb]
-                       x11-libs/libxcb:=
-                       x11-libs/xcb-util
-                       x11-libs/xcb-util-wm
-               )
-       )
-       pulseaudio? (
-               media-libs/libsndfile
-               media-sound/pulseaudio
-       )
-       purple? ( net-im/pidgin )
-       speech? ( >=app-accessibility/speech-dispatcher-0.8.7 )
-       systemd? ( sys-apps/systemd:= )
-       upnp? ( net-libs/gssdp:= )
-       webhook? ( >=net-libs/libsoup-2.42:2.4 )
-       websocket? ( >=net-libs/libsoup-2.50:2.4 )
-       zeroconf? ( net-dns/avahi[dbus] )
-"
-DEPEND="${COMMON_DEPEND}
-       >=dev-util/meson-0.44.1
-       app-text/docbook-xml-dtd:4.5
-       app-text/docbook-xsl-stylesheets
-       dev-libs/libxslt
-       virtual/pkgconfig
-       fbcon? ( virtual/os-headers )
-"
-RDEPEND="${COMMON_DEPEND}
-       net-libs/glib-networking[ssl]
-"
-
-pkg_setup() {
-       if use ipv6; then
-               CONFIG_CHECK=$(usex test 'IPV6' '~IPV6')
-               linux-info_pkg_setup
-       fi
-}
-
-src_prepare() {
-       default_src_prepare
-
-       # Prevent access violations from introspection metadata generation.
-       xdg_environment_reset
-}
-
-eventd_use_enable() {
-       echo "-D${2:-${1}}=$(usex ${1} 'true' 'false')" || die
-}
-
-src_configure() {
-       local emesonargs=(
-               -Dsystemduserunitdir="$(systemd_get_userunitdir)"
-               -Dsystemdsystemunitdir="$(systemd_get_systemunitdir)"
-               -Ddbussessionservicedir="${EPREFIX}/usr/share/dbus-1/services"
-               $(eventd_use_enable websocket)
-               $(eventd_use_enable zeroconf dns-sd)
-               $(eventd_use_enable upnp ssdp)
-               $(eventd_use_enable ipv6)
-               $(eventd_use_enable systemd)
-               $(eventd_use_enable notification notification-daemon)
-               # Wayland plugin requires wayland-wall, which is currently WIP.
-               # See https://github.com/wayland-wall/wayland-wall/issues/1
-               -Dnd-wayland="false"
-               $(eventd_use_enable X nd-xcb)
-               $(eventd_use_enable fbcon nd-fbdev)
-               $(eventd_use_enable purple im)
-               $(eventd_use_enable pulseaudio sound)
-               $(eventd_use_enable speech tts)
-               $(eventd_use_enable webhook)
-               $(eventd_use_enable libnotify)
-               $(eventd_use_enable libcanberra)
-               $(eventd_use_enable introspection gobject-introspection)
-               $(eventd_use_enable debug)
-       )
-       meson_src_configure
-}
-
-src_test() {
-       EVENTD_TESTS_TMP_DIR="${T}" meson_src_test
-}
-
-pkg_postinst() {
-       if { use notification || use libnotify; } && ! has_version 'gnome-base/librsvg'; then
-               elog
-               elog "For SVG icons in notifications, please install 'gnome-base/librsvg'."
-               elog
-       fi
-}