sys-process/cronie: Security cleanup
authorLars Wendler <polynomial-c@gentoo.org>
Thu, 6 Jun 2019 10:06:55 +0000 (12:06 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Thu, 6 Jun 2019 10:07:22 +0000 (12:07 +0200)
Bug: https://bugs.gentoo.org/685848
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-process/cronie/Manifest
sys-process/cronie/cronie-1.5.2.ebuild [deleted file]
sys-process/cronie/files/cronie-1.5.2-systemd.patch [deleted file]

index 67b6243c32d5b64818e84fa4de3d1e77254745e1..caf878723a890f37318beaedc6a431ca9bc15cff 100644 (file)
@@ -1,2 +1 @@
-DIST cronie-1.5.2.tar.gz 121604 BLAKE2B 4225439fd13a32bba3bd24f25d7dd405cdb123e666ebbf14574143af9d161867f82ea3fc479d81a884590faaa9c42e19c971285e01a19d6ac793b7deb7fc4775 SHA512 6455e234becc44e6568fa25fd72abfaa293cb0bc2d2f1d124e551c068ba01083192b21e82e941158c8c1f41cb6dad3851d665b9f3baa82fd49080f3f8619740b
 DIST cronie-1.5.4.tar.gz 122452 BLAKE2B 042961390807c22aa1db3ab592470538d9a348d33fee8f088dfa20e45ee72c72d9502bf5eb5a957494c55d99a6705b94774442f5a2fb06eeab1aa0b0e1a4d6ae SHA512 40a8cd750bc18dcb264e88cf049b0ea66f053b7b6cc10f38fd4f4e6b912871f41ce7ad126521a08203e81c00846e001016b47da3c5e8730a7b49fc970d7b2a6a
diff --git a/sys-process/cronie/cronie-1.5.2.ebuild b/sys-process/cronie/cronie-1.5.2.ebuild
deleted file mode 100644 (file)
index f0233d3..0000000
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools cron flag-o-matic pam systemd user
-
-DESCRIPTION="Cronie is a standard UNIX daemon cron based on the original vixie-cron"
-HOMEPAGE="https://github.com/cronie-crond/cronie"
-SRC_URI="https://github.com/cronie-crond/cronie/archive/${P}.tar.gz"
-
-LICENSE="ISC BSD BSD-2 GPL-2"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86"
-IUSE="+anacron +inotify pam selinux"
-
-DEPEND="pam? ( virtual/pam )
-       anacron? ( !sys-process/anacron
-               elibc_musl? ( sys-libs/obstack-standalone )
-       )"
-RDEPEND="${DEPEND}
-       sys-apps/debianutils"
-
-#cronie supports /etc/crontab
-CRON_SYSTEM_CRONTAB="yes"
-
-S="${WORKDIR}/${PN}-${P}"
-
-PATCHES=(
-       "${FILESDIR}/${PN}-1.5.2-systemd.patch"
-)
-
-pkg_setup() {
-       enewgroup crontab
-}
-
-src_prepare() {
-       default
-       eautoreconf
-}
-
-src_configure() {
-       local myeconfargs=(
-               $(use_with inotify)
-               $(use_with pam)
-               $(use_with selinux)
-               $(use_enable anacron)
-               --enable-syscrontab
-               --with-daemon_username=cron
-               --with-daemon_groupname=cron
-       )
-
-       if use anacron; then
-               use elibc_musl && append-cflags "-lobstack"
-       fi
-       SPOOL_DIR="/var/spool/cron/crontabs" \
-       ANACRON_SPOOL_DIR="/var/spool/anacron" \
-       econf "${myeconfargs[@]}"
-}
-
-src_install() {
-       emake install DESTDIR="${D}"
-
-       docrondir -m 1730 -o root -g crontab
-       fowners root:crontab /usr/bin/crontab
-       fperms 2751 /usr/bin/crontab
-
-       newconfd "${S}"/crond.sysconfig ${PN}
-
-       insinto /etc
-       newins "${FILESDIR}/${PN}-crontab" crontab
-       newins "${FILESDIR}/${PN}-1.2-cron.deny" cron.deny
-
-       insinto /etc/cron.d
-       doins contrib/0hourly
-
-       newinitd "${FILESDIR}/${PN}-1.3-initd" ${PN}
-       newpamd "${FILESDIR}/${PN}-1.4.3-pamd" crond
-
-       systemd_newunit contrib/cronie.systemd cronie.service
-
-       if use anacron ; then
-               local anacrondir="/var/spool/anacron"
-               keepdir ${anacrondir}
-               fowners root:cron ${anacrondir}
-               fperms 0750 ${anacrondir}
-
-               insinto /etc
-               doins contrib/anacrontab
-
-               insinto /etc/cron.hourly
-               doins contrib/0anacron
-               fperms 0750 /etc/cron.hourly/0anacron
-       else
-               insinto /etc/cron.d
-               doins contrib/dailyjobs
-       fi
-
-       einstalldocs
-}
-
-pkg_postinst() {
-       cron_pkg_postinst
-
-       if [[ -n "${REPLACING_VERSIONS}" ]] ; then
-               ewarn "You should restart ${PN} daemon or else you might experience segfaults"
-               ewarn "or ${PN} not working reliably anymore."
-               einfo "(see https://bugs.gentoo.org/557406 for details.)"
-       fi
-}
diff --git a/sys-process/cronie/files/cronie-1.5.2-systemd.patch b/sys-process/cronie/files/cronie-1.5.2-systemd.patch
deleted file mode 100644 (file)
index 884e665..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-From 11d255eb05ae9814c16cd443a7710d99492e16c1 Mon Sep 17 00:00:00 2001
-From: Mike Gilbert <floppym@gentoo.org>
-Date: Mon, 13 Jul 2015 10:59:57 -0400
-Subject: [PATCH] Adjust systemd service unit for Gentoo
-
----
- contrib/cronie.systemd | 5 +++--
- 1 file changed, 3 insertions(+), 2 deletions(-)
-
-diff --git a/contrib/cronie.systemd b/contrib/cronie.systemd
-index ad46899..7a6c1a9 100644
---- a/contrib/cronie.systemd
-+++ b/contrib/cronie.systemd
-@@ -3,10 +3,11 @@ Description=Command Scheduler
- After=auditd.service nss-user-lookup.target systemd-user-sessions.service time-sync.target ypbind.service
- [Service]
--EnvironmentFile=/etc/sysconfig/crond
--ExecStart=/usr/sbin/crond -n $CRONDARGS
-+ExecStart=/usr/sbin/crond
- ExecReload=/bin/kill -HUP $MAINPID
- KillMode=process
-+Type=forking
-+PIDFile=/run/crond.pid
- [Install]
- WantedBy=multi-user.target
--- 
-2.4.5
-