move mkdir to pkg_postinst. fixes #135912
authorJohn N. Laliberte <allanonjl@gentoo.org>
Wed, 7 Jun 2006 14:09:47 +0000 (14:09 +0000)
committerJohn N. Laliberte <allanonjl@gentoo.org>
Wed, 7 Jun 2006 14:09:47 +0000 (14:09 +0000)
Package-Manager: portage-2.1_rc4-r2

x11-libs/pango/ChangeLog
x11-libs/pango/files/digest-pango-1.10.3
x11-libs/pango/pango-1.10.2.ebuild
x11-libs/pango/pango-1.10.3.ebuild
x11-libs/pango/pango-1.10.4.ebuild
x11-libs/pango/pango-1.12.2.ebuild
x11-libs/pango/pango-1.4.1-r1.ebuild
x11-libs/pango/pango-1.8.1-r1.ebuild

index 90646c8380ae6610baab98a51e21b406cd943743..b2c282145c185dcf8cc7c7cdf847f011f9bc9f37 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for x11-libs/pango
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.135 2006/04/30 21:10:03 allanonjl Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.136 2006/06/07 14:09:47 allanonjl Exp $
+
+  07 Jun 2006; John N. Laliberte <allanonjl@gentoo.org>
+  pango-1.4.1-r1.ebuild, pango-1.8.1-r1.ebuild, pango-1.10.2.ebuild,
+  pango-1.10.3.ebuild, pango-1.10.4.ebuild, -pango-1.12.1.ebuild,
+  pango-1.12.2.ebuild:
+  move mkdir to pkg_postinst.  fixes #135912
 
 *pango-1.12.2 (30 Apr 2006)
 
index 609a30efa09a58b3da0bf7381fa016b70137b422..78839a985088ad7c3cf8e72e6c2efb4a943a9157 100644 (file)
@@ -1 +1,3 @@
 MD5 6fc5097f9c10d90ed386e074cb22cf6f pango-1.10.3.tar.bz2 1184884
+RMD160 e1f6697fd0b986519496c8db078bc5ee9f48b644 pango-1.10.3.tar.bz2 1184884
+SHA256 2e6ad481cf175e0bc3031e375786f792f923877b619dcdc09de6baec2b5d0c19 pango-1.10.3.tar.bz2 1184884
index d652c48977f61378f0f902fb69702e8050026bfd..4f4db3cdf791e3e617d3a1472cf64b2cb9269df7 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.10.2.ebuild,v 1.10 2006/02/03 20:12:29 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.10.2.ebuild,v 1.11 2006/06/07 14:09:47 allanonjl Exp $
 
 inherit eutils gnome2
 
@@ -32,8 +32,6 @@ DEPEND="${RDEPEND}
                ~app-text/docbook-xml-dtd-4.1.2 )"
 
 DOCS="AUTHORS ChangeLog* NEWS README TODO*"
-USE_DESTDIR="1"
-
 
 pkg_setup() {
        if ! built_with_use -a x11-libs/cairo png X; then
@@ -65,9 +63,6 @@ src_install() {
        gnome2_src_install
 
        rm ${D}/etc/pango/pango.modules
-       use amd64 && mkdir ${D}/etc/pango/${CHOST}
-       use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && mkdir ${D}/etc/pango/${CHOST}
-
 }
 
 pkg_postinst() {
@@ -77,6 +72,7 @@ pkg_postinst() {
                use amd64 && PANGO_CONFDIR="/etc/pango/${CHOST}"
                use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && PANGO_CONFDIR="/etc/pango/${CHOST}"
                PANGO_CONFDIR=${PANGO_CONFDIR:=/etc/pango}
+               mkdir -p ${PANGO_CONFDIR}
                pango-querymodules > ${PANGO_CONFDIR}/pango.modules
        fi
 
index a1832215a87a93b47e60c5dcdaab205fca72bd40..9ed05dbcfc0785deb137846be8c248a9358ea2d2 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.10.3.ebuild,v 1.10 2006/04/21 20:22:37 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.10.3.ebuild,v 1.11 2006/06/07 14:09:47 allanonjl Exp $
 
 inherit eutils gnome2
 
@@ -32,8 +32,6 @@ DEPEND="${RDEPEND}
                ~app-text/docbook-xml-dtd-4.1.2 )"
 
 DOCS="AUTHORS ChangeLog* NEWS README TODO*"
-USE_DESTDIR="1"
-
 
 pkg_setup() {
        if ! built_with_use -a x11-libs/cairo png X; then
@@ -65,9 +63,6 @@ src_install() {
        gnome2_src_install
 
        rm ${D}/etc/pango/pango.modules
-       use amd64 && mkdir ${D}/etc/pango/${CHOST}
-       use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && mkdir ${D}/etc/pango/${CHOST}
-
 }
 
 pkg_postinst() {
@@ -77,6 +72,7 @@ pkg_postinst() {
                use amd64 && PANGO_CONFDIR="/etc/pango/${CHOST}"
                use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && PANGO_CONFDIR="/etc/pango/${CHOST}"
                PANGO_CONFDIR=${PANGO_CONFDIR:=/etc/pango}
+               mkdir -p ${PANGO_CONFDIR}
                pango-querymodules > ${PANGO_CONFDIR}/pango.modules
        fi
 
index eabc98f20fe4943e776c824b3a898d57a7e31b6d..c44473e99fbfab9984773d2d2c2b86725f62c81b 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.10.4.ebuild,v 1.1 2006/03/05 05:20:52 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.10.4.ebuild,v 1.2 2006/06/07 14:09:47 allanonjl Exp $
 
 inherit eutils gnome2
 
@@ -32,8 +32,6 @@ DEPEND="${RDEPEND}
                ~app-text/docbook-xml-dtd-4.1.2 )"
 
 DOCS="AUTHORS ChangeLog* NEWS README TODO*"
-USE_DESTDIR="1"
-
 
 pkg_setup() {
        if ! built_with_use -a x11-libs/cairo png X; then
@@ -66,9 +64,6 @@ src_install() {
        gnome2_src_install
 
        rm ${D}/etc/pango/pango.modules
-       use amd64 && mkdir ${D}/etc/pango/${CHOST}
-       use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && mkdir ${D}/etc/pango/${CHOST}
-
 }
 
 pkg_postinst() {
@@ -78,6 +73,7 @@ pkg_postinst() {
                use amd64 && PANGO_CONFDIR="/etc/pango/${CHOST}"
                use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && PANGO_CONFDIR="/etc/pango/${CHOST}"
                PANGO_CONFDIR=${PANGO_CONFDIR:=/etc/pango}
+               mkdir -p ${PANGO_CONFDIR}
                pango-querymodules > ${PANGO_CONFDIR}/pango.modules
        fi
 
index 947a558fa908c8c6941b3de5e094bb2ecc422d87..30af201626af1f744eeb9e48091c764aafdf7a54 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.12.2.ebuild,v 1.1 2006/04/30 21:10:03 allanonjl Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.12.2.ebuild,v 1.2 2006/06/07 14:09:47 allanonjl Exp $
 
 inherit eutils gnome2
 
@@ -57,9 +57,6 @@ src_install() {
        gnome2_src_install
 
        rm ${D}/etc/pango/pango.modules
-       use amd64 && mkdir ${D}/etc/pango/${CHOST}
-       use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && mkdir ${D}/etc/pango/${CHOST}
-
 }
 
 pkg_postinst() {
@@ -69,6 +66,7 @@ pkg_postinst() {
                use amd64 && PANGO_CONFDIR="/etc/pango/${CHOST}"
                use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && PANGO_CONFDIR="/etc/pango/${CHOST}"
                PANGO_CONFDIR=${PANGO_CONFDIR:=/etc/pango}
+               mkdir -p ${PANGO_CONFDIR}
                pango-querymodules > ${PANGO_CONFDIR}/pango.modules
        fi
 
index e716bfcb847e50c9c5dda5be017b354fd3215266..c128511aed5bd9e27dd596af2c348b21c6dc2cbc 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.4.1-r1.ebuild,v 1.6 2006/02/06 22:27:30 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.4.1-r1.ebuild,v 1.7 2006/06/07 14:09:47 allanonjl Exp $
 
 inherit gnome2 eutils
 
@@ -50,8 +50,6 @@ DOCS="AUTHORS ChangeLog README INSTALL NEWS TODO*"
 src_install() {
        gnome2_src_install
        rm ${D}/etc/pango/pango.modules
-       use amd64 && mkdir ${D}/etc/pango/${CHOST}
-       use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && mkdir ${D}/etc/pango/${CHOST}
 }
 
 pkg_postinst() {
@@ -60,8 +58,7 @@ pkg_postinst() {
                use amd64 && PANGO_CONFDIR="/etc/pango/${CHOST}"
                use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && PANGO_CONFDIR="/etc/pango/${CHOST}"
                PANGO_CONFDIR=${PANGO_CONFDIR:=/etc/pango/}
+               mkdir -p ${PANGO_CONFDIR}
                pango-querymodules > /${PANGO_CONFDIR}/pango.modules
        fi
 }
-
-USE_DESTDIR="1"
index f9f4ccca1c256380820cbd2981aff71990854195..de070da6d83d58820ff59b382e260c2f54b17b37 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.8.1-r1.ebuild,v 1.12 2006/02/06 22:27:30 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.8.1-r1.ebuild,v 1.13 2006/06/07 14:09:47 allanonjl Exp $
 
 inherit gnome2 eutils
 
@@ -62,9 +62,6 @@ src_install() {
        gnome2_src_install
 
        rm ${D}/etc/pango/pango.modules
-       use amd64 && mkdir ${D}/etc/pango/${CHOST}
-       use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && mkdir ${D}/etc/pango/${CHOST}
-
 }
 
 pkg_postinst() {
@@ -74,9 +71,8 @@ pkg_postinst() {
                use amd64 && PANGO_CONFDIR="/etc/pango/${CHOST}"
                use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && PANGO_CONFDIR="/etc/pango/${CHOST}"
                PANGO_CONFDIR=${PANGO_CONFDIR:=/etc/pango/}
+               mkdir -p ${PANGO_CONFDIR}
                pango-querymodules > /${PANGO_CONFDIR}/pango.modules
        fi
 
 }
-
-USE_DESTDIR="1"