dev-ros/rqt_srv: bump to 0.4.8 and update to split repo
authorAlexis Ballier <aballier@gentoo.org>
Tue, 25 Apr 2017 06:06:06 +0000 (08:06 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 25 Apr 2017 06:40:11 +0000 (08:40 +0200)
Package-Manager: Portage-2.3.5, Repoman-2.3.2

dev-ros/rqt_srv/Manifest
dev-ros/rqt_srv/metadata.xml
dev-ros/rqt_srv/rqt_srv-0.4.8.ebuild [new file with mode: 0644]
dev-ros/rqt_srv/rqt_srv-9999.ebuild

index 7bb8c4d74093009871a7fac050b5df5b997ec913..3d5fbc48e697f995e81d6685bfa85fc14288ff7a 100644 (file)
@@ -1 +1,2 @@
 DIST rqt_common_plugins-0.4.7.tar.gz 246977 SHA256 83153ad89c67551c3fb4f36cad7f056d90c559958ac80203e2aa4605beb49a7f SHA512 eb10a7c03bb079d939a9705a08e9194c83e020235a13ed2d4ff8e9c3c73e5abbd0a9bd7c00587135767497b155bb9516d7b4c2240fbe2118d7b0668d6ee32ab7 WHIRLPOOL b002f836ee0f5ea213ec31be8e59910c7c3c9508301389309e60eeb7dd35989ae4e4dfa5fa9ee592371f05e6cd842a6e3b0ccd6ac4ed7a9efd8d60c36b1e6d65
+DIST rqt_srv-0.4.8.tar.gz 3518 SHA256 3e15e172af2b2d3910090b37d1bbbf87d1e4c248ba4d7e9e2071d73761e52ed9 SHA512 dc3712e3f84d3baae7ccddf55a64b3543698dabb828273a2cd99af06fb8d6155941c277ac48023aa37eff2873d11cf150f2b4e2fc616d01576703f69f5a4289e WHIRLPOOL 8e2341fb45f988c97b56e7fe9bb773fe523e064fb9fa977dfae24e38c38b550828315371458caebe9c4e2276e7bed6427a71ef51b7fe62a5e949af412617ae19
index cb473d142b8e7ce5b6c875e4ff9f5c2ac8c49e79..816573d3dd7f8c3ab22ab2c665ff633465ffe649 100644 (file)
@@ -6,6 +6,6 @@
                <name>Gentoo ROS Project</name>
        </maintainer>
        <upstream>
-               <remote-id type="github">ros-visualization/rqt_common_plugins</remote-id>
+               <remote-id type="github">ros-visualization/rqt_srv</remote-id>
        </upstream>
 </pkgmetadata>
diff --git a/dev-ros/rqt_srv/rqt_srv-0.4.8.ebuild b/dev-ros/rqt_srv/rqt_srv-0.4.8.ebuild
new file mode 100644 (file)
index 0000000..3836309
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_srv"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for introspecting available ROS message types"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/rosmsg[${PYTHON_USEDEP}]
+       dev-ros/rospy[${PYTHON_USEDEP}]
+       dev-ros/rqt_gui[${PYTHON_USEDEP}]
+       dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+       dev-ros/rqt_msg[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
index 77675b6733afd3d8e8581cf6b84e6b318391b5a1..38363091706c20c7e3f4caa1504f088dd1b7ddc0 100644 (file)
@@ -1,12 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
 
 KEYWORDS="~amd64"
-ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_srv"
 PYTHON_COMPAT=( python2_7 )
-ROS_SUBDIR=${PN}
 
 inherit ros-catkin