app-editors/nedit: fix sed to use pipes
authorAmy Liffey <amynka@gentoo.org>
Sun, 22 Mar 2020 11:58:39 +0000 (12:58 +0100)
committerAmy Liffey <amynka@gentoo.org>
Sun, 22 Mar 2020 12:24:16 +0000 (13:24 +0100)
Closes: https://bugs.gentoo.org/711408
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Amy Liffey <amynka@gentoo.org>
app-editors/nedit/nedit-5.7.ebuild

index 69f74a487102bf7d09876002bb4d38e47ecc9de2..25f9ab97f1dba8e9ce89948a98aa2b46f1f4c4a1 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -35,16 +35,16 @@ src_prepare() {
        #respecting LDFLAGS, bug #208189
        default
        sed \
-               -e "s:bin/:${EPREFIX}/bin/:g" \
+               -e "s|bin/|${EPREFIX}/bin/|g" \
                -i Makefile source/preferences.c source/help_data.h source/nedit.c Xlt/Makefile || die
        sed \
-               -e "s:nc:neditc:g" -i doc/nc.pod || die
-       sed -i -e "s:CFLAGS=-O:CFLAGS=${CFLAGS}:" -e "s:check_tif_rule::" \
+               -e "s|nc|neditc|g" -i doc/nc.pod || die
+       sed -i -e "s|CFLAGS=-O|CFLAGS=${CFLAGS}|" -e "s|check_tif_rule||" \
                makefiles/Makefile.linux || die
-       sed -i -e "s:CFLAGS=-O:CFLAGS=${CFLAGS}:"                  \
-                  -e "s:MOTIFDIR=/usr/local:MOTIFDIR=${EPREFIX}/usr:" \
-                  -e "s:-lX11:-lX11 -lXmu -liconv:"                   \
-                  -e "s:check_tif_rule::"                             \
+       sed -i -e "s|CFLAGS=-O|CFLAGS=${CFLAGS}|"                  \
+                  -e "s|MOTIFDIR=/usr/local|MOTIFDIR=${EPREFIX}/usr|" \
+                  -e "s|-lX11|-lX11 -lXmu -liconv|"                   \
+                  -e "s|check_tif_rule||"                             \
                makefiles/Makefile.macosx || die
 }