app-emulation/cadvisor: 0.35.0 bump
authorWilliam Hubbs <williamh@gentoo.org>
Sat, 22 Feb 2020 22:40:04 +0000 (16:40 -0600)
committerWilliam Hubbs <williamh@gentoo.org>
Sat, 22 Feb 2020 22:40:04 +0000 (16:40 -0600)
Signed-off-by: William Hubbs <williamh@gentoo.org>
app-emulation/cadvisor/Manifest
app-emulation/cadvisor/cadvisor-0.35.0.ebuild [new file with mode: 0644]

index 1c786759897d35fdda8181977a03a0cc460933e7..5c05e93fe26fff85935c97bf561884d0fa2c2078 100644 (file)
@@ -1 +1,2 @@
 DIST cadvisor-0.34.0.tar.gz 5210189 BLAKE2B 48cf7ddc94e52f07a0e74868d00f4a45d45aa5233b518da46762743357c17cbe7f2971794deda9936a10c65724928a219c498bf6d2493266f5b0ea547d485cb6 SHA512 accb41afd4683413b846f9380229bfa54c88b3141be68492963444928e40e14fc28da3ce27b09746e29c4dfe6323cd6bea69181826367e830f284d6ab698c633
+DIST cadvisor-0.35.0.tar.gz 5268930 BLAKE2B 065619ee459062bb521e855ccfd576afe236863bdc203b65e53a7eb6aec7172b6b9bb1d4183667ed36c471becb09fd974d1e4f809cf614f4d0d03ea3b87c2f63 SHA512 9fdae170fd167e0b1a2b69112ff2ec081640a144490c04e364536cae71a90e2c2845857f35af81ec58d4addd3675fd86b045d1f1b99a3e281f6270ab5d2a70f3
diff --git a/app-emulation/cadvisor/cadvisor-0.35.0.ebuild b/app-emulation/cadvisor/cadvisor-0.35.0.ebuild
new file mode 100644 (file)
index 0000000..06fd94f
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+EGO_PN="github.com/google/cadvisor"
+COMMIT=49033161
+inherit golang-build golang-vcs-snapshot
+
+DESCRIPTION="Analyzes resource usage and performance characteristics of running containers"
+HOMEPAGE="https://github.com/google/cadvisor"
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 ISC MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+
+COMMON_DEPEND="acct-group/cadvisor
+       acct-user/cadvisor"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+src_prepare() {
+       sed -i -e "/go get/d" src/${EGO_PN}/build/assets.sh || die
+       sed -i -e "s/git describe.*/echo ${PV} )/"\
+               -e "s/git rev-parse --short HEAD.*/echo ${COMMIT} )/"\
+               src/${EGO_PN}/build/build.sh || die
+       default
+}
+
+src_compile() {
+       export -n GOCACHE XDG_CACHE_HOME
+       pushd "src/${EGO_PN}"
+       GO_FLAGS="-v -work -x" VERBOSE="true" GOPATH="${S}:$(get_golibdir_gopath)" emake build
+       popd || die
+}
+
+src_install() {
+       newinitd "${FILESDIR}"/${PN}.initd-r1 ${PN}
+       dobin src/${EGO_PN}/${PN}
+       keepdir /var/log/${PN}
+       fowners ${PN}:${PN} /var/log/${PN}
+}