net-analyzer/thcrut: Fix building with CFLAGS=-fno-common
authorJeroen Roovers <jer@gentoo.org>
Sun, 10 May 2020 14:20:48 +0000 (16:20 +0200)
committerJeroen Roovers <jer@gentoo.org>
Sun, 10 May 2020 14:21:53 +0000 (16:21 +0200)
- Respect CFLAGS
- Remove unused declarations of ip_tcp_sync_addr

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Closes: https://bugs.gentoo.org/show_bug.cgi?id=722138
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-analyzer/thcrut/files/thcrut-1.2.5-flags.patch [new file with mode: 0644]
net-analyzer/thcrut/files/thcrut-1.2.5-fno-common.patch [new file with mode: 0644]
net-analyzer/thcrut/thcrut-1.2.5-r2.ebuild [new file with mode: 0644]

diff --git a/net-analyzer/thcrut/files/thcrut-1.2.5-flags.patch b/net-analyzer/thcrut/files/thcrut-1.2.5-flags.patch
new file mode 100644 (file)
index 0000000..0a6bcaf
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/configure.in
++++ b/configure.in
+@@ -23,7 +23,7 @@
+ dnl
+ dnl Use these compiler flags if we have gcc.
+ dnl
+-if test $ac_cv_prog_gcc = yes; then
++if test $ac_cv_prog_gcc_not_on_gentoo = yes; then
+   CCOPTS='-O2 -Wall'
+   CFLAGS="$CCOPTS"
+ fi
diff --git a/net-analyzer/thcrut/files/thcrut-1.2.5-fno-common.patch b/net-analyzer/thcrut/files/thcrut-1.2.5-fno-common.patch
new file mode 100644 (file)
index 0000000..a934048
--- /dev/null
@@ -0,0 +1,20 @@
+--- a/src/discover_dispatch.c
++++ b/src/discover_dispatch.c
+@@ -81,7 +81,6 @@
+ unsigned short ip_tcp_sync_chksum;
+ unsigned short ip_tcp_fp_chksum;
+-struct sockaddr_in ip_tcp_sync_addr;
+ static dispatch_func_recv_t dispatch_funcs[] = {
+       dis_recvdummy,
+       dis_recv,
+--- a/src/discover_main.c
++++ b/src/discover_main.c
+@@ -22,7 +22,6 @@
+ extern struct _opt opt;
+ extern char ip_tcp_sync[];
+-struct sockaddr_in ip_tcp_sync_addr;
+ int rawsox;
+ #define DFL_HOSTS_PARALLEL    (5000)
diff --git a/net-analyzer/thcrut/thcrut-1.2.5-r2.ebuild b/net-analyzer/thcrut/thcrut-1.2.5-r2.ebuild
new file mode 100644 (file)
index 0000000..191ed44
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="Network discovery and fingerprinting tool"
+HOMEPAGE="http://www.thc.org/thc-rut/"
+SRC_URI="http://www.thc.org/thc-rut/${P}.tar.gz"
+
+LICENSE="free-noncomm PCRE GPL-1+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="
+       dev-libs/libpcre
+       net-libs/libnet:1.0
+       net-libs/libpcap
+"
+RDEPEND="
+       ${DEPEND}
+"
+DOCS=( ChangeLog FAQ README TODO thcrutlogo.txt )
+PATCHES=(
+       "${FILESDIR}"/${P}-configure.patch
+       "${FILESDIR}"/${P}-flags.patch
+       "${FILESDIR}"/${P}-fno-common.patch
+       "${FILESDIR}"/${P}-libnet.patch
+)
+
+src_prepare() {
+       rm -r Libnet-1.0.2a pcre-3.9 || die
+       default
+       eautoreconf
+}