media-libs/woff2: also install cli tools
authorHans de Graaff <graaff@gentoo.org>
Wed, 15 Apr 2020 08:32:01 +0000 (10:32 +0200)
committerHans de Graaff <graaff@gentoo.org>
Wed, 15 Apr 2020 08:32:16 +0000 (10:32 +0200)
Thanks for Wicher Minnaard in bug 688624 for
providing the initial patch.

Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
media-libs/woff2/woff2-1.0.2-r2.ebuild [new file with mode: 0644]

diff --git a/media-libs/woff2/woff2-1.0.2-r2.ebuild b/media-libs/woff2/woff2-1.0.2-r2.ebuild
new file mode 100644 (file)
index 0000000..9036f52
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Encode/decode WOFF2 font format"
+HOMEPAGE="https://github.com/google/woff2"
+SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x64-solaris"
+IUSE=""
+
+RDEPEND="app-arch/brotli"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+       local mycmakeargs=(
+               -DCMAKE_SKIP_RPATH=ON # needed, causes QA warnings otherwise
+               -DCANONICAL_PREFIXES=ON #661942
+       )
+       cmake-utils_src_configure
+}
+
+src_install() {
+       cmake-utils_src_install
+
+       dobin ${BUILD_DIR}/woff2_compress
+       dobin ${BUILD_DIR}/woff2_decompress
+       dobin ${BUILD_DIR}/woff2_info
+
+       einstalldocs
+}