games-roguelike/wrogue: Remove old
authorDavid Seifert <soap@gentoo.org>
Wed, 20 Dec 2017 21:30:26 +0000 (22:30 +0100)
committerDavid Seifert <soap@gentoo.org>
Thu, 21 Dec 2017 01:49:05 +0000 (02:49 +0100)
Package-Manager: Portage-2.3.16, Repoman-2.3.6

games-roguelike/wrogue/wrogue-0.8.0b.ebuild [deleted file]

diff --git a/games-roguelike/wrogue/wrogue-0.8.0b.ebuild b/games-roguelike/wrogue/wrogue-0.8.0b.ebuild
deleted file mode 100644 (file)
index 72da111..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils games
-
-DESCRIPTION="Gothic science fantasy roguelike game"
-HOMEPAGE="https://freecode.com/projects/wrogue"
-SRC_URI="mirror://gentoo/${P}.zip"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="media-libs/libsdl[video]"
-DEPEND="${RDEPEND}
-       app-arch/unzip"
-
-src_prepare() {
-       sed -i \
-               -e "/AppData\[0\]/ s:AppData.*:strcpy(AppData, \"${GAMES_DATADIR}/${PN}/\");:" \
-               src/lib/appdir.c \
-               || die "sed failed"
-       epatch "${FILESDIR}"/${P}-ldflags.patch
-}
-
-src_compile() {
-       local myCPPFLAGS="-std=c99 -Iinclude -Ilib -Iui -Igenerate"
-       local myCFLAGS="$(sdl-config --cflags) ${CFLAGS}"
-       emake -C src -f linux.mak STRIP_BINARY=NO \
-               CFLAGS="${myCPPFLAGS} ${myCFLAGS}" release
-}
-
-src_install() {
-       dogamesbin ${PN}
-       insinto "${GAMES_DATADIR}/${PN}"
-       doins -r data
-       dodoc changes.txt
-
-       newicon data/ui/icon.bmp ${PN}.bmp
-       make_desktop_entry ${PN} "Warp Rogue" /usr/share/pixmaps/${PN}.bmp
-
-       prepgamesdirs
-}