dev-java/commons-graph: Clean up old.
authorPatrice Clement <monsieurp@gentoo.org>
Tue, 6 Oct 2015 09:37:35 +0000 (09:37 +0000)
committerPatrice Clement <monsieurp@gentoo.org>
Tue, 6 Oct 2015 09:56:51 +0000 (09:56 +0000)
Package-Manager: portage-2.2.18
Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
dev-java/commons-graph/Manifest
dev-java/commons-graph/commons-graph-0.8.1_p20040118-r2.ebuild [deleted file]

index d17ed63ff64ed58cb092eda925877fbca7ba323f..674c558fec1ff9b3a13fc6461e8d603b8ae570b3 100644 (file)
@@ -1,2 +1 @@
 DIST commons-graph-0.1.tar.gz 96009 SHA256 b68f5c7132e9eea4872dfc0d5fd74c138d2489355540dff752a91311cbac040d SHA512 7214fd60eb348a7feee9c194f562e5a7cf1f211ba589d2a85eaae52ed3ced7089842405dfbd99413b1f06f87ea1a19d244989daa1e0f6fb857fa752647d52b16 WHIRLPOOL 90c014761b2a1f8572eba4339f2ea81ec34666a83c21ea27326b366f0089cc5f20a5d6bc53aefa1d09019114b34f424496af95a604c1b55b5bdfec879ab51a0b
-DIST graph2-0.8.1.cvs20040118.tar.gz 42653 SHA256 916e3ca83376acd9ca64ee87988c8a19dc86c6468d087ede82d1e05c14a5a142 SHA512 110f2365b9568a4059233c6c6e75aec1a52b4fdd9110d55f0a6b79df324f047bde87d49134d8ba73417223919ddce972dd4a3c86841f843dd0109ebb17177083 WHIRLPOOL e3cd70bc98187a4f581bfa60125cfbfd0490264582d8fe4f536f7ecfd12a2f8228b1ff64db5414f8fa95ea976be5db08a054eecbb86e098cba62cc8cedd6f4c1
diff --git a/dev-java/commons-graph/commons-graph-0.8.1_p20040118-r2.ebuild b/dev-java/commons-graph/commons-graph-0.8.1_p20040118-r2.ebuild
deleted file mode 100644 (file)
index 7a80de0..0000000
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-JAVA_PKG_IUSE="doc source test"
-
-inherit java-pkg-2 java-ant-2 eutils
-MY_PN=graph2
-MY_PV=${PV%%_*}.cvs${PV##*_p}
-MY_P=${MY_PN}-${MY_PV}
-API_PV=${PV%%_*}
-DESCRIPTION="A toolkit for managing graphs and graph based data structures"
-# There doesn't seem to be a real home page, so we'll point to a viewcvs
-HOMEPAGE="http://cvs.apache.org/viewcvs/jakarta-commons-sandbox/graph2/"
-# this was extracted from a source rpm at jpackage
-SRC_URI="mirror://gentoo/distfiles/${MY_P}.tar.gz"
-COMMON_DEP="
-       dev-java/commons-collections
-       dev-java/jdepend"
-DEPEND=">=virtual/jdk-1.3
-       test? ( dev-java/ant-junit )
-       ${COMMON_DEP}"
-RDEPEND=">=virtual/jre-1.3
-       ${COMMON_DEP}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-S=${WORKDIR}/${MY_P}
-
-src_unpack(){
-       unpack ${A}
-       cd "${S}"
-       epatch "${FILESDIR}/${P}-gentoo.diff"
-       mkdir -p target/lib
-       cd target/lib
-       java-pkg_jar-from commons-collections
-       java-pkg_jar-from jdepend
-}
-
-src_install(){
-       java-pkg_newjar target/${PN}-${API_PV}.jar ${PN}.jar
-       use doc && java-pkg_dojavadoc dist/docs/api
-       use source && java-pkg_dosrc src/java/*
-}
-
-src_test() {
-       cd "${S}/target/lib"
-       java-pkg_jar-from junit
-       cd "${S}"
-       ANT_TASKS="ant-junit" eant test
-}