net-proxy/cntlm: use #!/sbin/openrc-run instead of #!/sbin/runscript
authorAustin English <wizardedit@gentoo.org>
Tue, 3 May 2016 18:52:50 +0000 (13:52 -0500)
committerAustin English <wizardedit@gentoo.org>
Tue, 3 May 2016 19:17:01 +0000 (14:17 -0500)
Gentoo-Bug: https://bugs.gentoo.org/573846

Package-Manager: portage-2.2.26

net-proxy/cntlm/cntlm-0.93_beta5-r2.ebuild [new file with mode: 0644]
net-proxy/cntlm/files/cntlm.initd

diff --git a/net-proxy/cntlm/cntlm-0.93_beta5-r2.ebuild b/net-proxy/cntlm/cntlm-0.93_beta5-r2.ebuild
new file mode 100644 (file)
index 0000000..bd7cbb1
--- /dev/null
@@ -0,0 +1,57 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils systemd toolchain-funcs user
+
+DESCRIPTION="Cntlm is an NTLM/NTLMv2 authenticating HTTP proxy"
+HOMEPAGE="http://cntlm.sourceforge.net/"
+SRC_URI="http://ftp.awk.cz/pub/${P//_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${P//_}"
+
+src_prepare() {
+       eapply -p0 "${FILESDIR}"/${P}-buildsystem.patch # 334647
+
+       default
+}
+
+src_configure() {
+       tc-export CC
+
+       econf
+
+       # Replace default config file path in Makefile
+       sed -i -e 's~SYSCONFDIR=/usr/local/etc~SYSCONFDIR=/etc~' \
+                               "${S}"/Makefile || die "sed failed"
+}
+
+src_compile() {
+       emake V=1
+}
+
+src_install() {
+       dobin cntlm
+       dodoc COPYRIGHT README VERSION doc/cntlm.conf
+       doman doc/cntlm.1
+       newinitd "${FILESDIR}"/cntlm.initd cntlm
+       newconfd "${FILESDIR}"/cntlm.confd cntlm
+       systemd_dounit "${FILESDIR}"/cntlm.service
+       insinto /etc
+       insopts -m0600
+       doins doc/cntlm.conf
+}
+
+pkg_postinst() {
+       enewgroup cntlm
+       enewuser cntlm -1 -1 -1 cntlm
+}
index daa19e32313a11985f1cfb091eb2dbb91b83d89f..6ebe838144245891e8f5e5c6c3a676afc9298aae 100644 (file)
@@ -1,5 +1,5 @@
-#!/sbin/runscript
-# Copyright 1999-2011 Gentoo Foundation
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$