dev-qt/qtwayland: Add USE vulkan
authorAndreas Sturmlechner <asturm@gentoo.org>
Wed, 26 Feb 2020 20:37:41 +0000 (21:37 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 26 Feb 2020 21:56:43 +0000 (22:56 +0100)
Closes: https://bugs.gentoo.org/703594
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-qt/qtwayland/metadata.xml
dev-qt/qtwayland/qtwayland-5.14.1-r1.ebuild

index 4fb03e679017fe0984f046570a12cc9e5231fbcf..db7a41ae479b00d93ca52da2e7e55ef7f958a48c 100644 (file)
@@ -7,6 +7,7 @@
        </maintainer>
        <use>
                <flag name="libinput">Enable support for input devices via <pkg>dev-libs/libinput</pkg></flag>
+               <flag name="vulkan">Enable support for Vulkan-based server buffer integration</flag>
        </use>
        <upstream>
                <bugs-to>https://bugreports.qt.io/</bugs-to>
index 0602db2ff59579ae4786d23ab2a0c482c092c317..5fa75b673a705f918f7469ab78839271e62b0af4 100644 (file)
@@ -10,15 +10,16 @@ if [[ ${QT5_BUILD_TYPE} == release ]]; then
        KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
 fi
 
-IUSE="+libinput xcomposite"
+IUSE="+libinput vulkan xcomposite"
 
 DEPEND="
        >=dev-libs/wayland-1.6.0
        ~dev-qt/qtcore-${PV}
        ~dev-qt/qtdeclarative-${PV}
-       ~dev-qt/qtgui-${PV}[egl,libinput=]
+       ~dev-qt/qtgui-${PV}[egl,libinput=,vulkan=]
        media-libs/mesa[egl]
        >=x11-libs/libxkbcommon-0.2.0
+       vulkan? ( dev-util/vulkan-headers )
        xcomposite? (
                x11-libs/libX11
                x11-libs/libXcomposite
@@ -37,6 +38,10 @@ src_prepare() {
                src/plugins/shellintegration/xdg-shell-v6/xdg-shell-v6.pro \
                tests/auto/compositor/compositor/compositor.pro
 
+       qt_use_disable_config vulkan wayland-vulkan-server-buffer \
+               src/plugins/hardwareintegration/client/client.pro \
+               src/plugins/hardwareintegration/compositor/compositor.pro
+
        use xcomposite || rm -r config.tests/xcomposite || die
 
        qt5-build_src_prepare