dev-python/mygpoclient: Commit updated patch
authorPacho Ramos <pacho@gentoo.org>
Sun, 11 Nov 2018 18:34:23 +0000 (19:34 +0100)
committerPacho Ramos <pacho@gentoo.org>
Sun, 11 Nov 2018 18:34:32 +0000 (19:34 +0100)
Bug: https://bugs.gentoo.org/615548
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11

dev-python/mygpoclient/files/mygpoclient-1.8-tests.patch [new file with mode: 0644]
dev-python/mygpoclient/mygpoclient-1.8.ebuild

diff --git a/dev-python/mygpoclient/files/mygpoclient-1.8-tests.patch b/dev-python/mygpoclient/files/mygpoclient-1.8-tests.patch
new file mode 100644 (file)
index 0000000..94a37be
--- /dev/null
@@ -0,0 +1,34 @@
+diff -Naur a/mygpoclient/locator_test.py b/mygpoclient/locator_test.py
+--- a/mygpoclient/locator_test.py      2018-03-27 02:18:57.711105496 -0300
++++ b/mygpoclient/locator_test.py      2018-03-27 02:22:02.201109125 -0300
+@@ -16,7 +16,7 @@
+ # along with this program.  If not, see <http://www.gnu.org/licenses/>.
+ from mygpoclient import locator
+-import unittest
++import unittest, sys
+ class Test_Exceptions(unittest.TestCase):
+     def setUp(self):
+@@ -54,18 +54,21 @@
+                 podcast='http://example.org/episodes.rss',
+                 device_id='gpodder')
++    @unittest.skipIf(hasattr(sys, 'pypy_version_info'), "pypy doesn't raise ValueError")
+     def test_device_settings_uri_exception(self):
+         """Test if using no parameter for a device Setting raises a ValueError"""
+         self.assertRaises(ValueError,
+                           self.locator.settings_uri, type='device',
+                           scope_param1=None, scope_param2=None)
++    @unittest.skipIf(hasattr(sys, 'pypy_version_info'), "pypy doesn't raise ValueError")
+     def test_podcast_settings_uri_exception(self):
+         """Test if using no parameter for a podcast Setting raises a ValueError"""
+         self.assertRaises(ValueError,
+                           self.locator.settings_uri, type='podcast',
+                           scope_param1=None, scope_param2=None)
++    @unittest.skipIf(hasattr(sys, 'pypy_version_info'), "pypy doesn't raise ValueError")
+     def test_episode_settings_uri_exception(self):
+         """Test if only using one parameter for a episode Setting raises a ValueError"""
+         self.assertRaises(ValueError,
index bb56a43f3a055dfbf2e54ca5972d1ece1f08fc80..aeb31ddbad67a15828929caaa879cdb9b5a1e058 100644 (file)
@@ -24,7 +24,7 @@ DEPEND="${RDEPEND}
        )
 "
 
-PATCHES=( "${FILESDIR}"/tests.patch )
+PATCHES=( "${FILESDIR}"/${P}-tests.patch )
 
 src_prepare() {
        distutils-r1_src_prepare