app-misc/linux-logo: 6.0 bump
authorBernard Cafarelli <voyageur@gentoo.org>
Mon, 11 May 2020 17:16:56 +0000 (19:16 +0200)
committerBernard Cafarelli <voyageur@gentoo.org>
Mon, 11 May 2020 17:17:06 +0000 (19:17 +0200)
Almost 10 years after previous release

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
app-misc/linux-logo/Manifest
app-misc/linux-logo/files/linux-logo-6.0-configure.patch [new file with mode: 0644]
app-misc/linux-logo/linux-logo-6.0.ebuild [new file with mode: 0644]

index 053a018722df7e118b12010096852a0c88ba6e16..d9fe570152f62e99bda988dc9cce6b393d25d64d 100644 (file)
@@ -1 +1,2 @@
 DIST linux_logo-5.11.tar.gz 103623 BLAKE2B 5790bae07a9496a690e0ef2d6426a68365c4ab91df058a31a5bffed38b8f3caac01b80ce49d52583f77632cc5e3061a20a5530437ca3508e823eeb88eb2e94cb SHA512 3c11d59eeb1ea613eb66d3ea5ef2d7c9ef906cb12430b9350570a6a1937ec174bdd974e6227358339c3fd2e0647a5066a0bea22289c4aa9bc8b03afb0033f114
+DIST linux_logo-6.0.tar.gz 117486 BLAKE2B 3340b893574f0c18561b208824cd80cff19c387d981af6ca63f56e691cebd2030e058ef367d91a999fd662592582da38b21a5a31f3f8364dbd87a43bd2c2b608 SHA512 ebd7513f90e79bb21acd984c671a1d1ce8421411d2b2948b01e6e08f7c9826184f9b9d528e0cfc814df8d8015d444a09c45025c344115ac9a6c2cff5743f03ad
diff --git a/app-misc/linux-logo/files/linux-logo-6.0-configure.patch b/app-misc/linux-logo/files/linux-logo-6.0-configure.patch
new file mode 100644 (file)
index 0000000..05df945
--- /dev/null
@@ -0,0 +1,78 @@
+diff -Naur linux_logo-6.0.orig/configure linux_logo-6.0/configure
+--- linux_logo-6.0.orig/configure      2020-05-08 07:37:08.000000000 +0200
++++ linux_logo-6.0/configure   2020-05-11 19:00:57.894062221 +0200
+@@ -41,31 +41,8 @@
+    XGETTEXT=xgettext
+ fi
+-which gcc
+-GCC_MISSING=$?
+-
+-if [ $GCC_MISSING -eq 1 ]; then
+-   which cc
+-   CC_MISSING=$?
+-   if [ $CC_MISSING -eq 1 ]; then
+-      echo "C compiler not found!"
+-   else
+-      CC=cc   
+-   fi
+-else
+-   CC=gcc
+-fi
+-
+ LIBSYSINFO=libsysinfo-0.3.0
+-LDFLAGS=""
+-
+-if [ $CC = gcc ]; then
+-   CFLAGS="-Wall -O2"
+-else
+-   CFLAGS="-O2"
+-fi   
+-
+ $CROSS$CC $CFLAGS -c intl_test.c 
+ INTL_MISSING=$?
+diff -Naur linux_logo-6.0.orig/libsysinfo-0.3.0/configure linux_logo-6.0/libsysinfo-0.3.0/configure
+--- linux_logo-6.0.orig/libsysinfo-0.3.0/configure     2020-05-08 07:37:08.000000000 +0200
++++ linux_logo-6.0/libsysinfo-0.3.0/configure  2020-05-11 19:01:09.551071479 +0200
+@@ -15,39 +15,6 @@
+ PREFIX=/usr/local
+ INSTALL=`which install`
+-which gcc
+-GCC_MISSING=$?
+-
+-if [ $GCC_MISSING -eq 1 ]; then
+-   which cc
+-   CC_MISSING=$?
+-   if [ $CC_MISSING -eq 1 ]; then
+-      echo "C compiler not found!"
+-   else
+-      CC=cc   
+-   fi
+-else
+-   CC=gcc
+-fi
+-
+-which ar
+-AR_MISSING=$?
+-
+-if [ $AR_MISSING -eq 0 ]; then
+-   AR=ar
+-fi
+-
+-
+-if [ $OS = SunOS ]; then
+-   AR=/usr/ccs/bin/ar
+-fi
+-   
+-if [ $CC = gcc ]; then
+-   CFLAGS="-Wall -O2"
+-else
+-   CFLAGS="-O2"
+-fi   
+-
+ LIBSYSINFO_INCLUDE="-I.."
+ LFLAGS=""
diff --git a/app-misc/linux-logo/linux-logo-6.0.ebuild b/app-misc/linux-logo/linux-logo-6.0.ebuild
new file mode 100644 (file)
index 0000000..5d00ccd
--- /dev/null
@@ -0,0 +1,76 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs systemd
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="A utility that displays an ANSI/ASCII logo and some system information"
+HOMEPAGE="http://www.deater.net/weave/vmwprod/linux_logo/"
+SRC_URI="http://www.deater.net/weave/vmwprod/linux_logo/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="nls"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )"
+
+PATCHES=(
+       "${FILESDIR}"/"${P}"-configure.patch
+)
+
+DOCS=( BUGS README README.CUSTOM_LOGOS TODO USAGE LINUX_LOGO.FAQ )
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+       cp "${FILESDIR}"/logo-config "${S}/logo_config" || die
+       cp "${FILESDIR}"/linux_logo_creator "${S}/" || die
+       cp "${FILESDIR}"/linux-logo.service "${S}/" || die
+       cp "${FILESDIR}"/gentoo-*.logo "${S}"/logos/ || die
+
+       sed -e 's#=$(PREFIX)#=$(DESTDIR)$(PREFIX)#' -i po/Makefile || die
+       default
+}
+
+src_configure() {
+       ARCH="" CC="$(tc-getCC)" AR="$(tc-getAR)" LDFLAGS="${LDFLAGS}" DESTDIR="${D}" \
+               ./configure --prefix=/usr || die
+}
+
+src_install() {
+       default
+
+       dobin "${FILESDIR}"/linux_logo_creator
+       newinitd "${FILESDIR}"/${PN}.init.d ${PN}
+       newconfd "${FILESDIR}"/${PN}-5.11.conf ${PN}
+
+       # systemd support
+       systemd_newunit "${FILESDIR}/linux-logo.service" "linux-logo.service"
+}
+
+pkg_postinst() {
+       echo
+       elog "Linux_logo ebuild for Gentoo comes with two Gentoo logos."
+       elog ""
+       elog "To display the first Gentoo logo type: linux_logo -L gentoo"
+       elog "To display the second Gentoo logo type: linux_logo -L gentoo-alt"
+       elog "To display all the logos available type: linux_logo -L list."
+       elog ""
+       elog "To start linux_logo on boot, please type:"
+       elog "   rc-update add linux-logo default"
+       elog "or for systemd"
+       elog "   systemctl enable linux-logo.service"
+       elog "which uses the settings found in"
+       elog "   /etc/conf.d/linux-logo"
+       echo
+}
+
+pkg_prerm() {
+       # Restore issue files
+       mv /etc/issue.linux-logo.backup /etc/issue 2> /dev/null
+       mv /etc/issue.net.linux-logo.backup /etc/issue.net 2> /dev/null
+}