app-admin/puppet-agent: 6.6.0 stable amd64/x86 with cleanup
authorMatthew Thode <prometheanfire@gentoo.org>
Mon, 22 Jul 2019 14:33:48 +0000 (09:33 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Mon, 22 Jul 2019 14:37:13 +0000 (09:37 -0500)
Package-Manager: Portage-2.3.66, Repoman-2.3.16
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
app-admin/puppet-agent/Manifest
app-admin/puppet-agent/puppet-agent-5.5.14.ebuild [deleted file]
app-admin/puppet-agent/puppet-agent-6.6.0.ebuild

index d5c53966297b89046a83e6f3377370a788e1202b..fb1d124ddc38b7e0745ca6c51ab943b9676fd995 100644 (file)
@@ -1,5 +1,3 @@
-DIST puppet-agent_5.5.14-1stretch_amd64.deb 17369338 BLAKE2B bc0544d49f704b07fe058164eb9e1f3f9dc8613337942043a1f4d1359105c986b3b170fda076e8bb4fb74a4d0a423c434d27669410edefe7834ab633217e1ff6 SHA512 410f3e76a571f48456ce6e6b83a957fe33391db72c428d2518001ccce23d29e4911d740cb9c70903050f9a69c815fce8988caa1ba469742b334b1f61229f1a31
-DIST puppet-agent_5.5.14-1stretch_i386.deb 18294894 BLAKE2B 928ea0c7113dc6789a37b83f4499485d17f09cf7ac1ace5c3aad87f0a93e4143cd4763f61e42d35a7561d5438d7b5d70d6181ab7233f72eaccb67cc4d5388d18 SHA512 8ae02257cf729ce41e6437d9ee2f221884b0e49dda7b3fc04ef200487c937f258075f563817bb064a19c30ec19b790f4d9d03e240d8a363f2942cd613c579c1b
 DIST puppet-agent_6.4.2-1stretch_amd64.deb 18776024 BLAKE2B d8fd52357abb9649d74c9b7e54eb0f599cc2b6b1cbe8a4bdd3bd21c69904379dcda2fdea4e642d3f86bef846d1bdfb14eb8c3daed50958ad3add46bde96fe5d2 SHA512 b1bdbcb1cb87bbf4391073b0596d759e1386bd5b93046d25be112f1ddad6a0d4da162116dc9f85908de67bfd3d956a1c418faf39a85c3ed0d02f9891d4d9906c
 DIST puppet-agent_6.4.2-1stretch_i386.deb 19250972 BLAKE2B 8424047586f7747daf24901f7ba134bfcd1fc4db094fd458f4298251880b0446221575cc463c511a32a6f7cf4c635c95b6132631640b5091e48b1e7cec67b844 SHA512 0041b1e3ff1401b21f7d9ab3b3aee66d76e30acd4748571ff3ff595d7006008e0d9d3f4c28db85cccece0cf08595cf4a3342353f5b18ea3e02ae02a094e42e41
 DIST puppet-agent_6.6.0-1stretch_amd64.deb 19177382 BLAKE2B c8034e4a943394da7fd97756b3dfb59897f3d787a8f49743a4c42ed47db4411f6d0e125cf6984728a108e5070cc8e42ca0a203d2afdcce99e08ae38a6ebb9293 SHA512 f0d129b357feb6e5d05c080437910e119bbce0e97e36927c2f97d3d7fb8f54a0eb1503a74ffec3cef7fd29785fe97ffd53f04a4be6a35b558ee278af8871289b
diff --git a/app-admin/puppet-agent/puppet-agent-5.5.14.ebuild b/app-admin/puppet-agent/puppet-agent-5.5.14.ebuild
deleted file mode 100644 (file)
index e56b95f..0000000
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit eutils systemd unpacker user
-
-DESCRIPTION="general puppet client utils along with mcollective hiera and facter"
-HOMEPAGE="https://puppetlabs.com/"
-SRC_BASE="http://apt.puppetlabs.com/pool/stretch/puppet5/${PN:0:1}/${PN}/${PN}_${PV}-1stretch"
-SRC_URI="
-       amd64? ( ${SRC_BASE}_amd64.deb )
-       x86?   ( ${SRC_BASE}_i386.deb )"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="puppetdb selinux"
-RESTRICT="strip"
-
-CDEPEND="!app-admin/augeas
-       !app-admin/mcollective
-       !app-admin/puppet
-       !dev-ruby/hiera
-       !dev-ruby/facter
-       !app-emulation/virt-what"
-
-DEPEND="
-       ${CDEPEND}"
-RDEPEND="${CDEPEND}
-       app-portage/eix
-       sys-apps/dmidecode
-       sys-libs/glibc
-       sys-libs/readline:0/7
-       sys-libs/ncurses:0[tinfo]
-       selinux? (
-               sys-libs/libselinux[ruby]
-               sec-policy/selinux-puppet
-       )
-       puppetdb? ( >=dev-ruby/puppetdb-termini-5.0.1 )"
-
-S=${WORKDIR}
-
-pkg_setup() {
-       enewgroup puppet
-       enewuser puppet -1 -1 /var/run/puppet puppet
-}
-
-src_install() {
-       # conf.d
-       doconfd etc/default/puppet
-       doconfd etc/default/mcollective
-       doconfd etc/default/pxp-agent
-       # logrotate.d
-       insinto /etc/logrotate.d
-       doins etc/logrotate.d/pxp-agent
-       # puppet itself
-       insinto /etc/puppetlabs
-       doins -r etc/puppetlabs/*
-       # logdir for systemd
-       dodir var/log/puppetlabs/puppet/
-       fperms 0750 var/log/puppetlabs/puppet/
-       # the rest
-       insinto /opt
-       dodir opt/puppetlabs/puppet/cache
-       doins -r opt/*
-       fperms 0750 /opt/puppetlabs/puppet/cache
-       # init
-       newinitd "${FILESDIR}/puppet.initd" puppet
-       newinitd "${FILESDIR}/mcollective.initd" mcollective
-       systemd_dounit lib/systemd/system/puppet.service
-       systemd_dounit lib/systemd/system/mcollective.service
-       systemd_dounit lib/systemd/system/pxp-agent.service
-       systemd_newtmpfilesd "${FILESDIR}/puppet-agent.conf.tmpfilesd" puppet-agent.conf
-       # symlinks
-       chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
-       chmod 0755 "${D}//opt/puppetlabs/puppet/lib/virt-what/virt-what-cpuid-helper"
-       dosym ../../opt/puppetlabs/bin/facter /usr/bin/facter
-       dosym ../../opt/puppetlabs/bin/hiera /usr/bin/hiera
-       dosym ../../opt/puppetlabs/bin/mco /usr/bin/mco
-       dosym ../../opt/puppetlabs/bin/puppet /usr/bin/puppet
-       dosym ../../opt/puppetlabs/puppet/bin/mcollectived /usr/sbin/mcollectived
-       dosym ../../opt/puppetlabs/puppet/bin/virt-what /usr/bin/virt-what
-       dosym ../../opt/puppetlabs/puppet/bin/augparse /usr/bin/augparse
-       dosym ../../opt/puppetlabs/puppet/bin/augtool /usr/bin/augtool
-}
index a72df734d6b1b21733754723bc01e47b1e426792..c648209a4a7e85f4e52398f06574ad8d2e769942 100644 (file)
@@ -13,7 +13,7 @@ SRC_URI="
 
 LICENSE="Apache-2.0"
 SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
 IUSE="puppetdb selinux"
 RESTRICT="strip"