dev-ruby/oauth2: cleanup
authorHans de Graaff <graaff@gentoo.org>
Tue, 6 Feb 2018 06:38:35 +0000 (07:38 +0100)
committerHans de Graaff <graaff@gentoo.org>
Wed, 7 Feb 2018 06:30:29 +0000 (07:30 +0100)
Package-Manager: Portage-2.3.19, Repoman-2.3.6

dev-ruby/oauth2/Manifest
dev-ruby/oauth2/oauth2-1.3.1.ebuild [deleted file]

index bb7f93a2652feabf791729d0aad6458d95baad2b..cc19652cd1b6c5ef41271c51e825e3794fc6af54 100644 (file)
@@ -1,2 +1 @@
-DIST oauth2-1.3.1.tar.gz 21371 BLAKE2B 3102918d211ae2b100b1cdf6c99727749e8ca11f8f861aee86e0ac81bc4c611c27a211575f349b914b9226679f24338efa7ce03b81f1d8cee2a1a0b570c42a7b SHA512 6ea4ce6c711c101f8cfe1450624e5bfe501114dd7888d663e0f5171de9f0efa0957483f1350dfc5bcf5d3a63240b194373df733395fac3fea2fcd55d22e4262a
 DIST oauth2-1.4.0.tar.gz 21299 BLAKE2B 1fe4640b374450279e556477c23972030d3aecac4c96e9174e57458deaccfbfa012e3bb66fe3db5e845a4004b91b763dab6f68b885ed7c1ddb2710cda29a8486 SHA512 2db67cba2403be8ea5d6f88f9818f295c29c08201f8ea5876c55cffe2fa926be465a11061654adffd77d13da9c7e56353ece7e4595cd9501acdcfeb58573b300
diff --git a/dev-ruby/oauth2/oauth2-1.3.1.ebuild b/dev-ruby/oauth2/oauth2-1.3.1.ebuild
deleted file mode 100644 (file)
index 94f9427..0000000
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-USE_RUBY="ruby21 ruby22 ruby23"
-
-RUBY_FAKEGEM_TASK_TEST="none"
-RUBY_FAKEGEM_TASK_DOC="doc:rdoc"
-
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="Wrapper for the OAuth 2.0 protocol with a similar style to the OAuth gem"
-HOMEPAGE="https://github.com/intridea/oauth2"
-SRC_URI="https://github.com/intridea/oauth2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/faraday-0.8
-       >=dev-ruby/jwt-1.0 =dev-ruby/jwt-1*
-       >=dev-ruby/multi_json-1.3 =dev-ruby/multi_json-1*
-       >=dev-ruby/multi_xml-0.5:0
-       >=dev-ruby/rack-1.2:* <dev-ruby/rack-3:*"
-ruby_add_bdepend "test? ( >=dev-ruby/rspec-2.5.0:2 )"
-
-all_ruby_prepare() {
-       sed -i -e '/simplecov/,/^  end/ s:^:#:' spec/helper.rb || die
-
-       sed -i -e '/yardstick/,/^end/ s:^:#:' \
-               -e '/bundler/I s:^:#:' Rakefile || die
-}
-
-each_ruby_test() {
-       CI=true ${RUBY} -S rspec spec || die
-}