net-misc/eventd: bump to 0.27.0
authorJoonas Niilola <juippis@gentoo.org>
Wed, 23 Oct 2019 04:33:54 +0000 (07:33 +0300)
committerJoonas Niilola <juippis@gentoo.org>
Wed, 23 Oct 2019 04:33:54 +0000 (07:33 +0300)
Closes: https://bugs.gentoo.org/669984
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
net-misc/eventd/Manifest
net-misc/eventd/eventd-0.27.0.ebuild [new file with mode: 0644]

index 1f41444eb320deb2b8ee5dc93861e0271ad9c25d..eeb8ce809b98a426f177fcc9e18f925cfbe83dc6 100644 (file)
@@ -1,2 +1,3 @@
 DIST eventd-0.21.0.tar.xz 392080 BLAKE2B 14d01d46e07e650f392abca53716c1fd5a5d70f05fe006e8a230d38be610e36ee0369742d258b46697376317be4ff6a071166a45528ef2840159a1024057d6cc SHA512 5907d453c493c9f2332df506037027ef7df021b1e29a6773cf8bb5c32c7a301b65ca55d3e3ea40982d3e48b837738c97b5420309a45a550f409d8912636d1dae
 DIST eventd-0.24.1.tar.xz 184276 BLAKE2B cd14506d7f539bd6076540c713c7957d52db1fb3a4a09ad52d2b1d4ab4b3d3c31c8245063a85efcef1abbc127fa534c15db1b297f9f651ac113b3723842f76f2 SHA512 c99a42364796cf7421bbb3c8b0d0810e1933b226c8bc4f74240d276d40bd9b96aae5d6016b8da92435222572fd1bf04441a63039f14162702f87aa0bdd4d67ed
+DIST eventd-0.27.0.tar.xz 188000 BLAKE2B 06779168e9049714aabc051f8a85a5e5764509c3deceddd300c103f4831b6679f082748858bebb9629dcd47fa0b570158c6cf2b665167ab8e20a7dc0f12cc00f SHA512 586fdf36742cfda5a3c5e4cf4600307b8d699701fdf32eec25a7b294c815ded6e7e41210e65c706c34c5f2d911cadec89b677f082dad183f486fb7d1a55a2302
diff --git a/net-misc/eventd/eventd-0.27.0.ebuild b/net-misc/eventd/eventd-0.27.0.ebuild
new file mode 100644 (file)
index 0000000..b377335
--- /dev/null
@@ -0,0 +1,105 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info meson systemd
+
+DESCRIPTION="A small daemon to act on remote or local events"
+HOMEPAGE="https://www.eventd.org/"
+SRC_URI="https://www.eventd.org/download/eventd/${P}.tar.xz"
+
+LICENSE="GPL-3+ LGPL-3+ ISC MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug fbcon +introspection ipv6 libcanberra libnotify +notification
+       pulseaudio purple speech systemd test upnp wayland webhook websocket
+       +X zeroconf"
+
+REQUIRED_USE="
+       X? ( notification )
+       fbcon? ( notification )
+       notification? ( || ( X fbcon ) )
+       test? ( websocket )
+"
+
+COMMON_DEPEND="
+       dev-libs/glib:2
+       sys-apps/util-linux
+       x11-libs/libxkbcommon
+       introspection? ( dev-libs/gobject-introspection )
+       libcanberra? ( media-libs/libcanberra )
+       libnotify? ( x11-libs/gdk-pixbuf:2 )
+       notification? (
+               gnome-base/librsvg
+               x11-libs/cairo
+               x11-libs/pango
+               x11-libs/gdk-pixbuf:2
+               X? (
+                       x11-libs/cairo[xcb]
+                       x11-libs/libxcb:=
+                       x11-libs/xcb-util
+                       x11-libs/xcb-util-wm
+               )
+       )
+       pulseaudio? (
+               media-libs/libsndfile
+               media-sound/pulseaudio
+       )
+       purple? ( net-im/pidgin )
+       speech? ( app-accessibility/speech-dispatcher )
+       systemd? ( sys-apps/systemd:= )
+       upnp? ( net-libs/gssdp:= )
+       wayland? ( dev-libs/wayland )
+       webhook? ( net-libs/libsoup:2.4 )
+       websocket? ( net-libs/libsoup:2.4 )
+       zeroconf? ( net-dns/avahi[dbus] )
+"
+DEPEND="${COMMON_DEPEND}
+       app-text/docbook-xml-dtd:4.5
+       app-text/docbook-xsl-stylesheets
+       dev-libs/libxslt
+       fbcon? ( virtual/os-headers )
+"
+RDEPEND="${COMMON_DEPEND}
+       net-libs/glib-networking[ssl]
+"
+BDEPEND="virtual/pkgconfig"
+
+pkg_setup() {
+       if use ipv6; then
+               CONFIG_CHECK=$(usex test 'IPV6' '~IPV6')
+               linux-info_pkg_setup
+       fi
+}
+
+src_configure() {
+       local emesonargs=(
+               -Dsystemduserunitdir="$(systemd_get_userunitdir)"
+               -Dsystemdsystemunitdir="$(systemd_get_systemunitdir)"
+               -Ddbussessionservicedir="${EPREFIX}/usr/share/dbus-1/services"
+               $(meson_feature websocket)
+               $(meson_feature zeroconf dns-sd)
+               $(meson_feature upnp ssdp)
+               $(meson_use ipv6)
+               $(meson_use systemd)
+               $(meson_use notification notification-daemon)
+               $(meson_use wayland)
+               $(meson_use X nd-xcb)
+               $(meson_use fbcon nd-fbdev)
+               $(meson_use purple im)
+               $(meson_use pulseaudio sound)
+               $(meson_use speech tts)
+               $(meson_use webhook)
+               $(meson_use libnotify)
+               $(meson_use libcanberra)
+               $(meson_use introspection gobject-introspection)
+               $(meson_use debug debug-output)
+       )
+
+       meson_src_configure
+}
+
+src_test() {
+       EVENTD_TESTS_TMP_DIR="${T}" meson_src_test
+}