Revision bump - various ebuild changes. Bug #158541
authorPeter Weller <welp@gentoo.org>
Thu, 4 Jan 2007 22:36:58 +0000 (22:36 +0000)
committerPeter Weller <welp@gentoo.org>
Thu, 4 Jan 2007 22:36:58 +0000 (22:36 +0000)
Package-Manager: portage-2.1.1-r2

net-im/gajim/ChangeLog
net-im/gajim/files/digest-gajim-0.11-r1 [new file with mode: 0644]
net-im/gajim/gajim-0.11-r1.ebuild [new file with mode: 0644]

index e82a11b53ce2041af856a236fb6470cbd81d0dbb..45b8ae6934814e6486c8ea132f8cd1555c87f4e1 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for net-im/gajim
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/ChangeLog,v 1.24 2007/01/03 17:17:40 welp Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/ChangeLog,v 1.25 2007/01/04 22:36:58 welp Exp $
+
+*gajim-0.11-r1 (04 Jan 2007)
+
+  04 Jan 2007; Peter Weller (welp) <welp@gentoo.org> -gajim-0.11.ebuild,
+  +gajim-0.11-r1.ebuild:
+  Revision bump - various ebuild changes. Bug #158541
 
 *gajim-0.11 (03 Jan 2007)
 
diff --git a/net-im/gajim/files/digest-gajim-0.11-r1 b/net-im/gajim/files/digest-gajim-0.11-r1
new file mode 100644 (file)
index 0000000..3d99559
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 7ac7ac6fdfc515cb927adf21793856fa gajim-0.11.tar.bz2 2684957
+RMD160 ff92f3914eb14596f725a47efa04acb402053723 gajim-0.11.tar.bz2 2684957
+SHA256 1b660d2516b918fdba7533aab3dead8c222c98964ea459c5e4204c4949055422 gajim-0.11.tar.bz2 2684957
diff --git a/net-im/gajim/gajim-0.11-r1.ebuild b/net-im/gajim/gajim-0.11-r1.ebuild
new file mode 100644 (file)
index 0000000..4a4171f
--- /dev/null
@@ -0,0 +1,63 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/gajim-0.11-r1.ebuild,v 1.1 2007/01/04 22:36:58 welp Exp $
+
+inherit multilib python
+
+DESCRIPTION="Jabber client written in PyGTK"
+HOMEPAGE="http://www.gajim.org/"
+SRC_URI="http://www.gajim.org/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="dbus gnome idle libnotify nls spell srv trayicon X xhtml"
+
+DEPEND="dev-python/pysqlite
+       dev-python/pygtk
+       sys-devel/gettext
+       dev-util/intltool
+       dev-util/pkgconfig"
+
+RDEPEND="gnome? ( dev-python/gnome-python-extras dev-python/gnome-python-desktop )
+       dbus? ( sys-apps/dbus )
+       dbus? ( libnotify? ( x11-libs/libnotify ) )
+       xhtml? ( dev-python/docutils )
+       srv? ( net-dns/bind-tools )
+       idle? ( x11-libs/libXScrnSaver )
+       spell? ( app-text/gtkspell )
+       avahi? ( net-dns/avahi )"
+
+pkg_setup() {
+       if use dbus && !build_with_use sys-apps/dbus python; then
+               eerror "Please rebuild dbus with USE=\"python\"."
+               die "Python D-Bus support missing"
+       fi
+}
+
+src_compile() {
+       econf \
+               $(use_enable nls ) \
+               $(use_enable spell gtkspell ) \
+               $(use_enable dbus remote ) \
+               $(use_with X x ) \
+               die || "Configure failed"
+       if !use gnome; then
+               econf \
+                       $(use_enable trayicon ) \
+                       $(use_enable idle ) \
+                       die || "Configure failed"
+       fi
+}
+
+src_install() {
+       emake PREFIX=/usr DESTDIR="${D}" LIBDIR=/$(get_libdir) install || die "Install failed"
+       dodoc README NEWS AUTHORS ChangeLog THANKS
+}
+
+pkg_postinst() {
+       python_mod_optimize /usr/share/gajim/
+}
+pkg_postrm() {
+       python_mod_cleanup /usr/share/gajim/
+}