dev-python/pyquery: Add python3_6
authorManuel Rüger <mrueg@gentoo.org>
Fri, 19 May 2017 14:00:06 +0000 (16:00 +0200)
committerManuel Rüger <mrueg@gentoo.org>
Fri, 19 May 2017 14:00:06 +0000 (16:00 +0200)
Package-Manager: Portage-2.3.5, Repoman-2.3.2

dev-python/pyquery/pyquery-1.2.13.ebuild

index d18653fb697882d38d3f19265e5b56b0db807455..e287f032c5b23d32ca3592e3b8167a9b33a211a0 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=5
 
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
 
 inherit distutils-r1 eutils
 
@@ -22,7 +22,6 @@ RDEPEND="
        >=dev-python/webob-1.1.9[${PYTHON_USEDEP}]"
 DEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
-       app-arch/unzip
        test? ( ${RDEPEND}
                dev-python/beautifulsoup[${PYTHON_USEDEP}]
                dev-python/requests[${PYTHON_USEDEP}]
@@ -30,6 +29,12 @@ DEPEND="
                dev-python/webtest[${PYTHON_USEDEP}]
                $(python_gen_cond_dep 'dev-python/restkit[${PYTHON_USEDEP}]' 'python2_7') )"
 
+python_prepare_all() {
+       # Disable tests needing a network connection
+       sed -i -e "s/HAS_REQUEST = True/HAS_REQUEST = False/" tests/test_pyquery.py || die
+       distutils-r1_python_prepare_all
+}
+
 python_test() {
        # The suite, it appears, requires this hard setting of PYTHONPATH!
        PYTHONPATH=. nosetests || die "Tests fail with ${EPYTHON}"