sys-fs/safecopy: EAPI 7
authorJames Le Cuirot <chewi@gentoo.org>
Sat, 7 Mar 2020 21:38:26 +0000 (21:38 +0000)
committerJames Le Cuirot <chewi@gentoo.org>
Sat, 7 Mar 2020 21:45:04 +0000 (21:45 +0000)
Installed files are unchanged.

Package-Manager: Portage-2.3.92, Repoman-2.3.20
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
sys-fs/safecopy/safecopy-1.7.ebuild

index dbfe2a87a2aa235d93696b0c630621fa005b2943..ea11400db3231fb79885b32b1e2a4ab23407b179 100644 (file)
@@ -1,9 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
-
-inherit base
+EAPI=7
 
 DESCRIPTION="Tool for fault-tolerant data recovery from damaged (io-errors) devices or files"
 HOMEPAGE="http://safecopy.sourceforge.net"
@@ -15,34 +13,20 @@ KEYWORDS="amd64 x86"
 IUSE="test"
 RESTRICT="!test? ( test )"
 
-RDEPEND=""
-DEPEND=""
-
 DOCS=( README )
 
-src_prepare() {
-       base_src_prepare
-       sed -e 's:bin/sh:bin/bash:' \
-               -i "${S}"/test/test.sh || die
-}
-
 src_configure() {
        econf
-       if use test; then
-               cd "${S}"/simulator
-               econf
-       fi
+       cd simulator || die
+       use test && econf
 }
 
 src_compile() {
        emake
-       if use test; then
-               cd "${S}"/simulator
-               emake
-       fi
+       use test && emake -C simulator
 }
 
 src_test() {
-       cd "${S}"/test
+       cd test || die
        ./test.sh || die
 }