sci-libs/scipy: Do not glob on DISTDIR
authorDavid Seifert <soap@gentoo.org>
Sun, 19 Mar 2017 12:44:15 +0000 (13:44 +0100)
committerDavid Seifert <soap@gentoo.org>
Sun, 19 Mar 2017 12:45:11 +0000 (13:45 +0100)
Bug: https://bugs.gentoo.org/show_bug.cgi?id=612920
Package-Manager: Portage-2.3.5, Repoman-2.3.2

sci-libs/scipy/scipy-0.15.1.ebuild
sci-libs/scipy/scipy-0.16.0.ebuild
sci-libs/scipy/scipy-0.16.1.ebuild
sci-libs/scipy/scipy-0.17.0.ebuild
sci-libs/scipy/scipy-0.18.1.ebuild

index 21b523cf8c51d739b31b4fb8094300be306fcbc2..e228f7d3d4dc723b2cf6bd9a2f8240dcfc827e84 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -123,7 +123,7 @@ sys.exit(0 if r.wasSuccessful() else 1)" || die "Tests fail with ${EPYTHON}"
 
 python_install_all() {
        if use doc; then
-               dodoc "${DISTDIR}"/${PN}*pdf
+               dodoc "${DISTDIR}"/${PN}-${DOC_PV}-ref.pdf
                docinto html
                dodoc -r "${WORKDIR}"/html/.
        fi
index 5cc5d81af80759568e31684dda3a6d4cf3d84f77..e404280c58045708f9fa4297450c72fd27aeffee 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -125,7 +125,7 @@ python_test() {
 
 python_install_all() {
        if use doc; then
-               dodoc "${DISTDIR}"/${PN}*pdf
+               dodoc "${DISTDIR}"/${PN}-${DOC_PV}-ref.pdf
                docinto html
                dodoc -r "${WORKDIR}"/html/.
        fi
index 2b2cbdd32e203e9f0b3cad921a9fd6a4d957056d..dd5908fb2319d59fd9e3d28359edeb08b7555eb7 100644 (file)
@@ -130,7 +130,7 @@ python_test() {
 
 python_install_all() {
        if use doc; then
-               dodoc "${DISTDIR}"/${PN}*pdf
+               dodoc "${DISTDIR}"/${PN}-${DOC_PV}-ref.pdf
                docinto html
                dodoc -r "${WORKDIR}"/html/.
        fi
index 43d3e39d6371352e6c235f0f810cb46530d8635e..ac2f5ad71e96b31fccc987e2ed07e1a2008c8be6 100644 (file)
@@ -131,7 +131,7 @@ python_test() {
 
 python_install_all() {
        use doc && \
-               local DOCS=( "${DISTDIR}"/${PN}*pdf ) \
+               local DOCS=( "${DISTDIR}"/${PN}-${DOC_PV}-ref.pdf ) \
                local HTML_DOCS=( "${WORKDIR}"/html/. )
        distutils-r1_python_install_all
 }
index 44a6f8669f1573f045ba781ab21ed9c081a73c6f..c1d9ea57af2278ea9ef65a0a9e2f5ee0b0a19dcc 100644 (file)
@@ -130,7 +130,7 @@ python_test() {
 
 python_install_all() {
        use doc && \
-               local DOCS=( "${DISTDIR}"/${PN}*pdf ) \
+               local DOCS=( "${DISTDIR}"/${PN}-${DOC_PV}-ref.pdf ) \
                local HTML_DOCS=( "${WORKDIR}"/html/. )
        distutils-r1_python_install_all
 }