sys-devel/gdb: use ${CHOST}-pkg-config, bug #716558
authorSergei Trofimovich <slyfox@gentoo.org>
Wed, 8 Apr 2020 07:42:55 +0000 (08:42 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Wed, 8 Apr 2020 07:43:28 +0000 (08:43 +0100)
When cross-compiling gdb ./configure found CBUILD's
dev-util/source-highlight. That is never correct as client
is supposed to be running on CHOST.

The change switches to CHOST's PKG_CONFIG.

Reported-by: Jan Postránský
Bug: https://bugs.gentoo.org/716558
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
sys-devel/gdb/gdb-9.1.ebuild
sys-devel/gdb/gdb-9999.ebuild

index 85e667269711bd44993d8a702d41c0f9f5170857..9361fca6fb0cb3ac19ba1c4543a8139281806a60 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=7
 PYTHON_COMPAT=( python{3_6,3_7} )
 
-inherit eutils flag-o-matic python-single-r1
+inherit eutils flag-o-matic python-single-r1 toolchain-funcs
 
 export CTARGET=${CTARGET:-${CHOST}}
 if [[ ${CTARGET} == ${CHOST} ]] ; then
@@ -183,6 +183,9 @@ src_configure() {
                myconf+=( --disable-largefile )
        fi
 
+       # source-highlight is detected with pkg-config: bug #716558
+       export ac_cv_path_pkg_config_prog_path="$(tc-getPKG_CONFIG)"
+
        mkdir "${GDB_BUILD_DIR}" || die
        pushd "${GDB_BUILD_DIR}" || die
                ECONF_SOURCE=${S}
index 9e181d9e64bfccd28d5ae50f39c9042f341c9feb..056b99bbc890b785e0700ffc3d35847273b6fbca 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=7
 PYTHON_COMPAT=( python{3_6,3_7} )
 
-inherit eutils flag-o-matic python-single-r1
+inherit eutils flag-o-matic python-single-r1 toolchain-funcs
 
 export CTARGET=${CTARGET:-${CHOST}}
 if [[ ${CTARGET} == ${CHOST} ]] ; then
@@ -181,6 +181,9 @@ src_configure() {
                myconf+=( --disable-largefile )
        fi
 
+       # source-highlight is detected with pkg-config: bug #716558
+       export ac_cv_path_pkg_config_prog_path="$(tc-getPKG_CONFIG)"
+
        econf "${myconf[@]}"
 }