app-metrics/fusioninventory-agent: Fix config path
authorAlexey Shvetsov <alexxy@gentoo.org>
Wed, 27 May 2020 07:15:59 +0000 (10:15 +0300)
committerAlexey Shvetsov <alexxy@gentoo.org>
Wed, 27 May 2020 07:16:17 +0000 (10:16 +0300)
Package-Manager: Portage-2.3.100, Repoman-2.3.22
Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
app-metrics/fusioninventory-agent/files/fusioninventory-agent-2.5.2-dirs.patch
app-metrics/fusioninventory-agent/fusioninventory-agent-2.5.2.ebuild

index d4c0f4eadb0f0958eb9d4c75418d8a89aba9758d..e37b58c43a0cb3b5e1266604936d0837a5a982ec 100644 (file)
      );
  
      # allow variables defined on command line to override defaults
+--- a/lib/FusionInventory/Agent/Config.pm     2020-05-27 10:06:21.248964808 +0300
++++ b/lib/FusionInventory/Agent/Config.pm     2020-05-27 10:06:57.324964823 +0300
+@@ -67,7 +67,7 @@
+     my ($class, %params) = @_;
+     my $self = {
+-        '_confdir' => undef, # SYSCONFDIR replaced here from Makefile
++        '_confdir' => '/etc/fusioninventory', # SYSCONFDIR replaced here from Makefile
+     };
+     bless $self, $class;
+     $self->_loadDefaults();
+
index 3350194f9c03b11bdf0fdf2fd6ba6fcf33f84a82..9b0a5d9d145c8526c8246aa5809cf002ca3fb435 100644 (file)
@@ -36,7 +36,7 @@ PATCHES=( "${FILESDIR}/${P}-dirs.patch" )
 src_install() {
        default
        systemd_dounit contrib/unix/fusioninventory-agent.service
-       doinitd "${FILESDIR}/${PN}.initd"
-       doconfd "${FILESDIR}/${PN}.confd"
+       newinitd "${FILESDIR}/${PN}.initd" ${PN}
+       newconfd "${FILESDIR}/${PN}.confd" ${PN}
        keepdir /var/lib/fusioninventory
 }