dev-libs/gjs: bump to 1.58.6
authorMart Raudsepp <leio@gentoo.org>
Sun, 29 Mar 2020 09:31:37 +0000 (12:31 +0300)
committerMart Raudsepp <leio@gentoo.org>
Sun, 29 Mar 2020 09:55:38 +0000 (12:55 +0300)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
dev-libs/gjs/Manifest
dev-libs/gjs/gjs-1.58.6.ebuild [new file with mode: 0644]

index 0c07395ac35f72196e92add660d08f6938c1024c..f68a3ea0b580aa297ae3c6572c5a22ca28d6ca45 100644 (file)
@@ -1,3 +1,4 @@
 DIST gjs-1.48.7.tar.xz 595324 BLAKE2B eac8b5b2f7e909e94e3fb305cac443da3f433047ee07fa8fbd15905890f77d57449c8689867df61f1ac849b8b4bddc089a9b1ddc3aa79d4b3d054226c58fa909 SHA512 b8c58e068eaecfca2fa40cebe209fa8058e603809be4307099a0f3dbd561752a540d587d546ffa74aef0268a111f2b2846a1e0febda1adcefdac8c02e716e2dd
 DIST gjs-1.56.2.tar.xz 701976 BLAKE2B 77057e4a3a8958d6648c92bb56495b505b3ec49bc0eeff0fa5c9e3ae5a694a4b5643dc72d7aa673f9e66d42e9b0def7f9df0043f2690216bfc5c5109ea9eca51 SHA512 687b8e3795565b5c56fceebefb229c07b4c084a4f65c0035e0d185d12082920424632c0f896df8dc1cd5013a97b6e08274efaec4caeb564dc2070d26a5f974c5
 DIST gjs-1.58.5.tar.xz 637996 BLAKE2B a6c96ee4be81e36d4675d24d9b66b9aab83fe7e4c4cac042122f095b477b551234785417f796144c6755e5faf4afeee446f00a5914a9d63d0619f74fbb2a5694 SHA512 18ef3afc4403ed281e1e70a379fd68ffa537ffc20ab66d7faaefe51e03bb6a66e359e5ca2c0511e1c5f8c6adfce93601d011cfb9e9e6b0a18f8aa1f2398297c3
+DIST gjs-1.58.6.tar.xz 637972 BLAKE2B 553f29808723e48cee39c62e260d9c09f5db160756bf6c2fc45e532bee1d5c8babdd2bd5aee39fdff1300fc10de2c2a4e34d6b850e6e95c83ef217a8955379b6 SHA512 3e8fa8ccaabbbd07e74869fdc6188cffc19565798a6267fd3480d9320a2c9c5906c864e5d0c6e9e57f7bb79cc1706717b76b23c7cd89eb191477eb173b24aa74
diff --git a/dev-libs/gjs/gjs-1.58.6.ebuild b/dev-libs/gjs/gjs-1.58.6.ebuild
new file mode 100644 (file)
index 0000000..ee4c6cf
--- /dev/null
@@ -0,0 +1,64 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2 pax-utils virtualx
+
+DESCRIPTION="Javascript bindings for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Projects/Gjs"
+
+LICENSE="MIT || ( MPL-1.1 LGPL-2+ GPL-2+ )"
+SLOT="0"
+IUSE="+cairo examples gtk readline +sysprof test"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+       >=dev-libs/glib-2.58.0
+       >=dev-libs/gobject-introspection-1.61.2:=
+
+       readline? ( sys-libs/readline:0= )
+       dev-lang/spidermonkey:60
+       dev-libs/libffi:=
+       cairo? ( x11-libs/cairo[X] )
+"
+DEPEND="${RDEPEND}
+       sysprof? ( >=dev-util/sysprof-capture-3.33.2:3 )
+       virtual/pkgconfig
+       test? ( sys-apps/dbus
+               >=x11-libs/gtk+-3.20:3 )
+"
+
+RESTRICT="!test? ( test )"
+
+src_configure() {
+       # FIXME: add systemtap/dtrace support, like in glib:2
+       # FIXME: --enable-systemtap installs files in ${D}/${D} for some reason
+       # XXX: Do NOT enable coverage, completely useless for portage installs
+       gnome2_src_configure \
+               --disable-systemtap \
+               --disable-dtrace \
+               --disable-code-coverage \
+               $(use_with cairo cairo) \
+               $(use_enable sysprof profiler) \
+               $(use_enable readline) \
+               $(use_with test dbus-tests) \
+               $(use_with test gtk-tests) \
+               --disable-installed-tests
+}
+
+src_install() {
+       # installation sometimes fails in parallel, bug #???
+       gnome2_src_install -j1
+
+       if use examples; then
+               insinto /usr/share/doc/"${PF}"/examples
+               doins "${S}"/examples/*
+       fi
+
+       # Required for gjs-console to run correctly on PaX systems
+       pax-mark mr "${ED}/usr/bin/gjs-console"
+}
+
+src_test() {
+       virtx emake check
+}