games-fps/eduke32: fix compilation with gcc-10
authorConrad Kostecki <conikost@gentoo.org>
Sat, 23 May 2020 13:57:20 +0000 (15:57 +0200)
committerConrad Kostecki <conikost@gentoo.org>
Sat, 23 May 2020 13:57:20 +0000 (15:57 +0200)
Closes: https://bugs.gentoo.org/724626
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
games-fps/eduke32/eduke32-20200505.8904.ebuild
games-fps/eduke32/files/eduke32-20200505.8904-gcc10.patch [new file with mode: 0644]

index c0662991c69904ffeea25f5ba0af3527ebdf8d84..c493f5f8a351923b56c8867faa74ba55da62aa93 100644 (file)
@@ -88,6 +88,7 @@ PATCHES=(
        "${FILESDIR}/${PN}-20190419.7615-wad2map-buildfix.patch"
        "${FILESDIR}/${PN}-20190820.8043-log-to-tmpdir.patch"
        "${FILESDIR}/${PN}-20190820.8043-search-duke3d-path.patch"
+       "${FILESDIR}/${PN}-20200505.8904-gcc10.patch"
 )
 
 src_unpack() {
diff --git a/games-fps/eduke32/files/eduke32-20200505.8904-gcc10.patch b/games-fps/eduke32/files/eduke32-20200505.8904-gcc10.patch
new file mode 100644 (file)
index 0000000..2795e99
--- /dev/null
@@ -0,0 +1,13 @@
+This patch fixes compilation with GCC-10.
+
+diff -dru a/source/audiolib/include/music.h b/source/audiolib/include/music.h
+--- a/source/audiolib/include/music.h
++++ b/source/audiolib/include/music.h
+@@ -38,6 +38,7 @@
+ #ifdef __linux__
+ #include <vector>
++#include <string>
+ typedef struct
+ {