x11-misc/trayer: Clean up git cruft in patches, use PKG_CONFIG
authorJeroen Roovers <jer@gentoo.org>
Wed, 20 Nov 2019 11:39:32 +0000 (12:39 +0100)
committerJeroen Roovers <jer@gentoo.org>
Wed, 20 Nov 2019 12:15:13 +0000 (13:15 +0100)
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
x11-misc/trayer/files/trayer-1.0-as-needed-and-pre-stripped.patch
x11-misc/trayer/files/trayer-1.0-dont-include-gdk-pixbuf-xlib.patch
x11-misc/trayer/files/trayer-1.0-dont-include-libXmu.patch
x11-misc/trayer/trayer-1.0-r3.ebuild
x11-misc/trayer/trayer-1.0-r4.ebuild

index 9db3384242207619ec01044e029c9bab180b1dbf..84f54a4bfdfaa5f8e7e360a58994bc6ee5a0caf0 100644 (file)
@@ -1,15 +1,3 @@
-From 6d0c1123441633660c2ec4f336e1e800b4dfebb5 Mon Sep 17 00:00:00 2001
-From: Harri Nieminen <moikkis@gmail.com>
-Date: Sat, 25 Mar 2017 12:18:13 +0200
-Subject: [PATCH 2/2] Fix for as-needed and pre-stripped files
-
-Gentoo bugs: #141707, #252098
----
- Makefile | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index 9d7c4fb..faaa85d 100644
 --- a/Makefile
 +++ b/Makefile
 @@ -36,9 +36,9 @@ endif
@@ -17,13 +5,10 @@ index 9d7c4fb..faaa85d 100644
  TARGET = trayer
  $(TARGET): $(OBJ) $(SYSTRAYOBJ)
 -      $(CC) $(LDFLAGS) $(LIBS) $(OBJ) $(SYSTRAYOBJ) -o $@
-+      $(CC) $(LDFLAGS) $(OBJ) $(SYSTRAYOBJ) $(LIBS) -o $@
++      $(CC) $(CFLAGS) $(LDFLAGS) $(OBJ) $(SYSTRAYOBJ) $(LIBS) -o $@
  ifeq (,$(DEVEL))
 -      strip $@
 +      true $@
  endif
  
  TARGETMAN = $(TARGET).1.gz
--- 
-2.12.1
-
index ccb1e12869b89a2f7e5fff9c6d353fddad298eb7..ecb013a37ad4a2da987b96292b9fb471f11fde67 100644 (file)
@@ -1,19 +1,3 @@
-From 1aa5f4164b86fd0c5cf174c8403442060cad497d Mon Sep 17 00:00:00 2001
-From: Harri Nieminen <moikkis@gmail.com>
-Date: Sat, 25 Mar 2017 12:17:09 +0200
-Subject: [PATCH 1/2] Remove useless include on
- gdk-pixbuf-xlib/gdk-pixbuf-xlib.h
-
-Also fix underlinking, bug #369591
-
-Thanks for leio@g.o for reporting
----
- Makefile.common | 4 ++--
- plugin.c        | 1 -
- 2 files changed, 2 insertions(+), 3 deletions(-)
-
-diff --git a/Makefile.common b/Makefile.common
-index 0d50340..ec2bc3c 100644
 --- a/Makefile.common
 +++ b/Makefile.common
 @@ -16,8 +16,8 @@ endif
@@ -22,13 +6,11 @@ index 0d50340..ec2bc3c 100644
  CC = gcc
 -LIBS = $(shell pkg-config --libs gtk+-2.0 gdk-pixbuf-2.0 gdk-pixbuf-xlib-2.0) -L/usr/X11R6/lib  -lXmu
 -INCS = $(shell pkg-config --cflags gtk+-2.0 gdk-pixbuf-2.0 gdk-pixbuf-xlib-2.0)
-+LIBS = $(shell pkg-config --libs gtk+-2.0 gdk-pixbuf-2.0 gmodule-2.0 x11)
-+INCS = $(shell pkg-config --cflags gtk+-2.0 gdk-pixbuf-2.0 gmodule-2.0 x11)
++LIBS = $(shell ${PKG_CONFIG} --libs gtk+-2.0 gdk-pixbuf-2.0 gmodule-2.0 x11)
++INCS = $(shell ${PKG_CONFIG} --cflags gtk+-2.0 gdk-pixbuf-2.0 gmodule-2.0 x11)
  CFLAGS = -O2    # overwriten by command line or env. variable
  CFLAGS += -Wall # always nice to have 
  ifneq (,$(DEVEL))
-diff --git a/plugin.c b/plugin.c
-index 7fd5398..a6f8fbb 100644
 --- a/plugin.c
 +++ b/plugin.c
 @@ -2,7 +2,6 @@
@@ -38,7 +20,3 @@ index 7fd5398..a6f8fbb 100644
 -#include <gdk-pixbuf-xlib/gdk-pixbuf-xlib.h>
  #include <gdk/gdk.h>
  #include <string.h>
--- 
-2.12.1
-
index 8b9fd291d15f83cd42eb44fcb81fb03f06437d1a..56f3000ff69ca44ad50871b93724ae86dcbf14e8 100644 (file)
@@ -1,14 +1,3 @@
-From 710efb0c8192e704a83fd3d4b8b3c0d6be984246 Mon Sep 17 00:00:00 2001
-From: Harri Nieminen <moikkis@gmail.com>
-Date: Sun, 26 Mar 2017 10:08:05 +0300
-Subject: [PATCH] Don't include libXmu
-
----
- systray/main.c | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/systray/main.c b/systray/main.c
-index dff5455..79cbe34 100644
 --- a/systray/main.c
 +++ b/systray/main.c
 @@ -2,7 +2,6 @@
@@ -19,6 +8,3 @@ index dff5455..79cbe34 100644
  #include <gdk-pixbuf/gdk-pixbuf.h>
  
  #include "panel.h"
--- 
-2.12.1
-
index 1d79f1312512a54027136ecc0b8b2156928bb95d..f130f5ec280ace2d4aaeb05d00f2aaaaaf9d5da1 100644 (file)
@@ -31,6 +31,8 @@ PATCHES=(
 )
 
 src_compile() {
+       tc-export PKG_CONFIG
+
        emake -j1 CC=$(tc-getCC) CFLAGS="${CFLAGS}" CPPFLAGS="${CPPFLAGS}"
 }
 
index 2e11ffd72f0f29c25db3d3964a591a4f78870d7e..eab20e2644252bb344af194a77698722dc4dc440 100644 (file)
@@ -30,6 +30,8 @@ PATCHES=(
 )
 
 src_compile() {
+       tc-export PKG_CONFIG
+
        emake "CC=$(tc-getCC)" CFLAGS="${CFLAGS}" CPPFLAGS="${CPPFLAGS}" -C systray
        emake "CC=$(tc-getCC)" CFLAGS="${CFLAGS}" CPPFLAGS="${CPPFLAGS}"
 }