dev-python/utidylib: Drop PYTHON_USEDEP from dev-python/sphinx
authorAndreas Sturmlechner <asturm@gentoo.org>
Sun, 24 Nov 2019 21:05:57 +0000 (22:05 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 24 Nov 2019 21:07:17 +0000 (22:07 +0100)
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-python/utidylib/utidylib-0.6.ebuild

index b37e9e1ddd2fe3542e293d826c2fc60042f26a42..5e18aa363d3ec8ab2f6ff9d9dbb92a780b5ce89b 100644 (file)
@@ -18,20 +18,20 @@ KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
 IUSE="doc test"
 
 REQUIRED_USE="${PYTHON_REQUIRED_USE}
-       doc? ( || ( $(python_gen_useflags 'python2*' python3_6 python3_7) ) )
        test? ( || ( $(python_gen_useflags 'python2*' python3_6 python3_7) ) )
 "
 
 BDEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( $(python_gen_cond_dep 'dev-python/sphinx[${PYTHON_USEDEP}]' 'python2*' python3_6 python3_7) )
-       test? (
-               $(python_gen_cond_dep 'dev-python/flake8[${PYTHON_USEDEP}]' 'python2*' python3_6 python3_7)
-               $(python_gen_cond_dep 'dev-python/pycodestyle[${PYTHON_USEDEP}]' 'python2*' python3_6 python3_7)
-               $(python_gen_cond_dep 'dev-python/pyflakes[${PYTHON_USEDEP}]' 'python2*' python3_6 python3_7)
-               $(python_gen_cond_dep 'dev-python/pytest[${PYTHON_USEDEP}]' 'python2*' python3_6 python3_7)
-               $(python_gen_cond_dep 'dev-python/pytest-cov[${PYTHON_USEDEP}]' 'python2*' python3_6 python3_7)
-       )
+       doc? ( dev-python/sphinx )
+       test? ( $(python_gen_cond_dep '
+               dev-python/flake8[${PYTHON_USEDEP}]
+               dev-python/pycodestyle[${PYTHON_USEDEP}]
+               dev-python/pyflakes[${PYTHON_USEDEP}]
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-python/pytest-cov[${PYTHON_USEDEP}]
+               ' 'python2*' python3_6 python3_7
+       ) )
 "
 DEPEND="
        dev-python/six[${PYTHON_USEDEP}]