net-vpn/nstx: Bump to EAPI 7
authorMichał Górny <mgorny@gentoo.org>
Sat, 9 Nov 2019 13:48:43 +0000 (14:48 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 9 Nov 2019 13:56:41 +0000 (14:56 +0100)
Closes: https://bugs.gentoo.org/697216
Signed-off-by: Michał Górny <mgorny@gentoo.org>
net-vpn/nstx/nstx-1.1_beta6-r3.ebuild

index 2da45c3bb9533fd759e6e3e197846a50ef395370..1bdf06b40b905b38dc5e4067b6addfebcbc70491 100644 (file)
@@ -1,56 +1,50 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
-inherit versionator toolchain-funcs eutils linux-info
+inherit toolchain-funcs linux-info
 
-MY_PV=$(replace_version_separator 2 - "${PV}")
-MY_P="${PN}-${MY_PV}"
+MY_P="${PN}-${PV/_/-}"
 DEBIAN_PV="5"
-DEBIAN_A="${PN}_${MY_PV}-${DEBIAN_PV}.diff.gz"
+DEBIAN_A="${MY_P/-/_}-${DEBIAN_PV}.diff.gz"
 
 DESCRIPTION="IP over DNS tunnel"
-SRC_URI="http://dereference.de/nstx/${MY_P}.tgz
-               mirror://debian/pool/main/${PN:0:1}/${PN}/${DEBIAN_A}"
 HOMEPAGE="http://dereference.de/nstx/"
-DEPEND="virtual/os-headers"
+SRC_URI="http://dereference.de/nstx/${MY_P}.tgz
+       mirror://debian/pool/main/${PN:0:1}/${PN}/${DEBIAN_A}"
+S="${WORKDIR}/${MY_P}"
+
 KEYWORDS="amd64 x86"
-IUSE=""
-LICENSE="GPL-2"
 SLOT="0"
-S="${WORKDIR}/${MY_P}"
+LICENSE="GPL-2+"
+IUSE=""
+
+DEPEND="virtual/os-headers"
 
 CONFIG_CHECK="~TUN"
 
-src_unpack() {
-       unpack "${MY_P}.tgz"
-       epatch "${DISTDIR}"/${DEBIAN_A} \
-               "${FILESDIR}"/${PN}-1.1_beta6_00-linux-tuntap.patch \
-               "${FILESDIR}"/${PN}-1.1_beta6_01-bind-interface-name.patch \
-               "${FILESDIR}"/${PN}-1.1_beta6_02-warn-on-frag.patch \
-               "${FILESDIR}"/${PN}-1.1_beta6_03-delete-dwrite.patch \
-               "${FILESDIR}"/${PN}-1.1_beta6_04-delete-werror.patch \
-               "${FILESDIR}"/${PN}-1.1_beta6_05-respect-ldflags.patch
-}
+PATCHES=(
+       "${WORKDIR}"/${DEBIAN_A%.gz}
+       "${FILESDIR}"/${PN}-1.1_beta6_00-linux-tuntap.patch
+       "${FILESDIR}"/${PN}-1.1_beta6_01-bind-interface-name.patch
+       "${FILESDIR}"/${PN}-1.1_beta6_02-warn-on-frag.patch
+       "${FILESDIR}"/${PN}-1.1_beta6_03-delete-dwrite.patch
+       "${FILESDIR}"/${PN}-1.1_beta6_04-delete-werror.patch
+       "${FILESDIR}"/${PN}-1.1_beta6_05-respect-ldflags.patch
+)
 
 src_compile() {
-       emake CC="$(tc-getCC)" || die
+       emake CC="$(tc-getCC)"
 }
 
 src_install() {
-       into /usr
-       dosbin nstxcd nstxd || die
-       dodoc README Changelog || die
-       doman *.8 || die
+       dosbin nstxcd nstxd
+       dodoc README Changelog
+       doman *.8
 
        newinitd "${FILESDIR}"/nstxd.init nstxd
        newconfd "${FILESDIR}"/nstxd.conf nstxd
        newinitd "${FILESDIR}"/nstxcd.init nstxcd
        newconfd "${FILESDIR}"/nstxcd.conf nstxcd
 }
-
-pkg_postinst() {
-       einfo "Please read the documentation provided in"
-       einfo "  `find /usr/share/doc/${PF}/ -name 'README*'`"
-}