media-sound/spotify: version bump to 1.0.88
authorNikos Chantziaras <realnc@gmail.com>
Sat, 18 Aug 2018 14:56:42 +0000 (17:56 +0300)
committerMatthew Thode <prometheanfire@gentoo.org>
Sat, 18 Aug 2018 20:22:26 +0000 (15:22 -0500)
Removed eutils, sorted inherits, fixed a typo in a comment, removed
gnome2_icon_savelist call, removed obsolete ewarn.

Closes: https://bugs.gentoo.org/663974
Package-Manager: Portage-2.3.47, Repoman-2.3.10

media-sound/spotify/Manifest
media-sound/spotify/spotify-1.0.88.ebuild [new file with mode: 0644]

index 759ddc645ab1fd6fb241650ac620ad14b58260c9..f5e0097423bf1d01f590251b0d89408af2748807 100644 (file)
@@ -1,2 +1,3 @@
 DIST spotify-client_1.0.72.117.g6bd7cc73-35_i386.deb 95135550 BLAKE2B ad4587dd6b3c64a0398e0790203a7826e290a27542fa39ebbd6c7198d8ad1fd3fb06e8b030b64e1e61e0624ef20aafda08189266486cd073cb779ebff62ef502 SHA512 51d60f7592e5f31ea4b7e67736a85271cb48d4108459630da61c4ab67d2a470038240c1d6ff577280cb4498cf44f14d7bc7e0312f63d34265bcd1e70cd13142f
 DIST spotify-client_1.0.80.480.g51b03ac3-13_amd64.deb 97542898 BLAKE2B a89f3f607c9fb03327886fc1b6eb8d433b32913aa7ff32e95f626a8ef7710c4d6102721b76e9a83f1342d1ac6f6941d85376b4cb878cf641f42f3c3756582eb9 SHA512 a46b1d28e6c40dbe9a86a38794186f2cdf31341fff953eaa5a5fdbb37c27c00ffe14a918b2552df0996d2842f009e6700bf8683e0667fc671dfd5b343251f20e
+DIST spotify-client_1.0.88.345.gc64d9bb3-2_amd64.deb 103366188 BLAKE2B 9c18dce84a2c4a634ddfe360539ecc590f3f85b7ab65063dfbc20ac102cfb06310592ae1f06deee5f09cc93179d887e917db2666bf53fd86ae026a883343787e SHA512 23207a2d5ec0bd6e1e614ea58576339146c210d1cb453e3e5eb4fa03b80f15e9ebae3cb38c1fec72ffd2f206a9d0476bab3a079ed0f9f0fbf1aefa40baabfa35
diff --git a/media-sound/spotify/spotify-1.0.88.ebuild b/media-sound/spotify/spotify-1.0.88.ebuild
new file mode 100644 (file)
index 0000000..68ca015
--- /dev/null
@@ -0,0 +1,115 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2-utils pax-utils unpacker xdg-utils
+
+DESCRIPTION="Spotify is a social music platform"
+HOMEPAGE="https://www.spotify.com/ch-de/download/previews/"
+SRC_BASE="http://repository.spotify.com/pool/non-free/s/${PN}-client/"
+BUILD_ID_AMD64="345.gc64d9bb3-2"
+#BUILD_ID_X86=""
+#SRC_URI="amd64? ( ${SRC_BASE}${PN}-client_${PV}.${BUILD_ID_AMD64}_amd64.deb )
+#      x86? ( ${SRC_BASE}${PN}-client_${PV}.${BUILD_ID_X86}_i386.deb )"
+SRC_URI="${SRC_BASE}${PN}-client_${PV}.${BUILD_ID_AMD64}_amd64.deb"
+LICENSE="Spotify"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libnotify systray pax_kernel pulseaudio"
+RESTRICT="mirror strip"
+
+DEPEND=">=dev-util/patchelf-0.9_p20180129"
+# zenity needed for filepicker
+RDEPEND="
+       dev-libs/openssl:0
+       dev-libs/nss
+       gnome-base/gconf
+       gnome-extra/zenity
+       media-libs/alsa-lib
+       media-libs/harfbuzz
+       media-libs/fontconfig
+       media-libs/mesa
+       net-misc/curl[ssl]
+       net-print/cups[ssl]
+       x11-libs/gtk+:2
+       x11-libs/libXScrnSaver
+       x11-libs/libXtst
+       dev-python/pygobject:3
+       dev-python/dbus-python
+       libnotify? ( x11-libs/libnotify )
+       pulseaudio? ( media-sound/pulseaudio )
+       systray? ( gnome-extra/gnome-integration-spotify )"
+       #sys-libs/glibc
+
+S=${WORKDIR}/
+
+QA_PREBUILT="opt/spotify/spotify-client/spotify"
+
+src_prepare() {
+       # Fix desktop entry to launch spotify-dbus.py for systray integration
+       if use systray ; then
+               sed -i \
+                       -e 's/spotify \%U/spotify-dbus.py \%U/g' \
+                       usr/share/spotify/spotify.desktop || die "sed failed"
+       fi
+       default
+
+       # Spotify links against libcurl-gnutls.so.4, which does not exist in Gentoo.
+       patchelf --replace-needed libcurl-gnutls.so.4 libcurl.so.4 usr/bin/spotify \
+               || die "failed to patch libcurl library dependency"
+}
+
+src_install() {
+       dodoc usr/share/doc/spotify-client/changelog.gz
+
+       SPOTIFY_PKG_HOME=usr/share/spotify
+       insinto /usr/share/pixmaps
+       doins ${SPOTIFY_PKG_HOME}/icons/*.png
+
+       # install in /opt/spotify
+       SPOTIFY_HOME=/opt/spotify/spotify-client
+       insinto ${SPOTIFY_HOME}
+       doins -r ${SPOTIFY_PKG_HOME}/*
+       fperms +x ${SPOTIFY_HOME}/spotify
+
+       dodir /usr/bin
+       cat <<-EOF >"${D}"/usr/bin/spotify || die
+               #! /bin/sh
+               exec ${SPOTIFY_HOME}/spotify "\$@"
+       EOF
+       fperms +x /usr/bin/spotify
+
+       local size
+       for size in 16 22 24 32 48 64 128 256 512; do
+               newicon -s ${size} "${S}${SPOTIFY_PKG_HOME}/icons/spotify-linux-${size}.png" \
+                       "spotify-client.png"
+       done
+       domenu "${S}${SPOTIFY_PKG_HOME}/spotify.desktop"
+       if use pax_kernel; then
+               #create the headers, reset them to default, then paxmark -m them
+               pax-mark C "${ED}${SPOTIFY_HOME}/${PN}" || die
+               pax-mark z "${ED}${SPOTIFY_HOME}/${PN}" || die
+               pax-mark m "${ED}${SPOTIFY_HOME}/${PN}" || die
+               eqawarn "You have set USE=pax_kernel meaning that you intend to run"
+               eqawarn "${PN} under a PaX enabled kernel.  To do so, we must modify"
+               eqawarn "the ${PN} binary itself and this *may* lead to breakage!  If"
+               eqawarn "you suspect that ${PN} is being broken by this modification,"
+               eqawarn "please open a bug."
+       fi
+}
+
+pkg_postinst() {
+       gnome2_icon_cache_update
+       xdg_mimeinfo_database_update
+       xdg_desktop_database_update
+
+       ewarn "If Spotify crashes after an upgrade its cache may be corrupt."
+       ewarn "To remove the cache:"
+       ewarn "rm -rf ~/.cache/spotify"
+}
+
+pkg_postrm() {
+       gnome2_icon_cache_update
+       xdg_mimeinfo_database_update
+       xdg_desktop_database_update
+}