www-apps/davical: remove vulnerable versions
authorTill Schäfer <till2.schaefer@uni-dortmund.de>
Thu, 12 Dec 2019 15:44:34 +0000 (16:44 +0100)
committerJoonas Niilola <juippis@gentoo.org>
Thu, 12 Dec 2019 17:53:34 +0000 (19:53 +0200)
Bug: https://bugs.gentoo.org/702514
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Signed-off-by: Till Schäfer <till2.schaefer@uni-dortmund.de>
Closes: https://github.com/gentoo/gentoo/pull/13956
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
www-apps/davical/Manifest
www-apps/davical/davical-1.1.7-r2.ebuild [deleted file]
www-apps/davical/davical-1.1.8.ebuild [deleted file]
www-apps/davical/files/davical-1.1.7-fix_php4_style_constructors.patch [deleted file]

index afcd675cdd10c8a8d8722345a050fd9e9623c6c0..e1b7f4932355dc4ee3526c5d92d3f63128d989b4 100644 (file)
@@ -1,3 +1 @@
-DIST davical-1.1.7.tar.xz 1347368 BLAKE2B 74418e99190db94dbb95fe9bdbed8f468cf98070a6ef86cb5af1f6460a97eb8c2faede7858a38b9728c5b3e400c6340f1abf3f00ae757847d8996b22e709f70e SHA512 d66388479259a8369f3a648a9d81f1e2f5488f6a3c4415360c133b21b6c6d4b4d433d5f94a635cffdaa0385a56c24176fa660ee8653d75246604655ccdd1a455
-DIST davical-1.1.8.tar.xz 1358060 BLAKE2B 9b38081981e876bfdb025bfb5cbd57843645e399df0816658c395ab8c2447809930596a4adcc7bb30f357435735a435c75b03431505eec24fd5adb270845fc39 SHA512 e4a81a80086cdb67af47202865ad1652e83f276d2b82fc80b8bff60682027c911f2000052b1f32008269c77147462ec21886eae78fb3b5d4247b747fb9c4d1e6
 DIST davical-1.1.9.2.tar.xz 1359636 BLAKE2B 6161e98dc4683310ec51ca1272f4869dd56711f6bd2f3aadf4481c847056c060a7d2811368587aea42377ff27ccdbaf0095d4fd915aec7c5b766fd7e073d25ef SHA512 025f6600fde809ef95708197e62523b400e06a187461221a4fa86326ebef2452857b1d433c25b0b50ee56df89040aec733fc597d8f966ab22720a8ce38a0f5b2
diff --git a/www-apps/davical/davical-1.1.7-r2.ebuild b/www-apps/davical/davical-1.1.7-r2.ebuild
deleted file mode 100644 (file)
index 9d2ef12..0000000
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit webapp
-
-DESCRIPTION="A CalDAV and CardDAV Server"
-HOMEPAGE="https://www.davical.org/"
-SRC_URI="https://www.davical.org/downloads/${PN}_${PV}.orig.tar.xz -> ${P}.tar.xz"
-
-LICENSE="GPL-2 GPL-2+ GPL-3+ LGPL-2.1+ LGPL-3+"
-KEYWORDS="~amd64 ~x86"
-IUSE="ldap"
-
-BDEPEND="sys-devel/gettext"
-
-RDEPEND="app-admin/pwgen
-       dev-lang/php:*[calendar,curl,iconv,imap,ldap?,nls,pdo,postgres,xml]
-       dev-perl/DBD-Pg
-       dev-perl/DBI
-       dev-perl/YAML
-       >=dev-php/awl-0.59
-       virtual/httpd-php"
-
-need_httpd
-
-PATCHES=( "${FILESDIR}/${P}-fix_php4_style_constructors.patch" )
-
-S="${WORKDIR}"
-
-src_compile() {
-       emake built-locale
-}
-
-src_install() {
-       webapp_src_preinst
-
-       einstalldocs
-
-       einfo "Installing web files"
-       insinto "${MY_HTDOCSDIR}"
-       doins -r htdocs/. htdocs/.htaccess
-
-       einfo "Installing main files and i18n"
-       insinto "${MY_HOSTROOTDIR}/${PN}"
-       doins -r inc locale
-       rm "${ED}/${MY_HOSTROOTDIR}/${PN}/inc/always.php.in" || die
-
-       einfo "Installing sql files"
-       insinto "${MY_SQLSCRIPTSDIR}"
-       doins -r dba/.
-
-       insinto /etc/${PN}
-       doins -r config/. "${FILESDIR}/vhost-example"
-
-       webapp_postinst_txt en "${FILESDIR}/postinstall-en.txt"
-       webapp_postupgrade_txt en "${FILESDIR}/postupgrade-en.txt"
-       webapp_src_install
-
-       fperms +x "${MY_SQLSCRIPTSDIR}/create-database.sh"
-       fperms +x "${MY_SQLSCRIPTSDIR}/update-davical-database"
-}
-
-pkg_postinst() {
-       elog "If you are upgrading from a previous version of davical, don't forget to"
-       elog "upgrade the database structure with"
-       elog "       cd /usr/share/webapps/davical/${PVR}/sqlscripts/"
-       elog "       ./update-davical-database -dbuser xxxxxxx -appuser xxxxxx"
-
-       webapp_pkg_postinst
-}
diff --git a/www-apps/davical/davical-1.1.8.ebuild b/www-apps/davical/davical-1.1.8.ebuild
deleted file mode 100644 (file)
index b7cc044..0000000
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit webapp
-
-DESCRIPTION="A CalDAV and CardDAV Server"
-HOMEPAGE="https://www.davical.org/"
-SRC_URI="https://www.davical.org/downloads/${PN}_${PV}.orig.tar.xz -> ${P}.tar.xz"
-
-LICENSE="GPL-2 GPL-2+ GPL-3+ LGPL-2.1+ LGPL-3+"
-KEYWORDS="~amd64 ~x86"
-IUSE="ldap"
-
-BDEPEND="sys-devel/gettext"
-
-RDEPEND="app-admin/pwgen
-       dev-lang/php:*[calendar,curl,iconv,imap,ldap?,nls,pdo,postgres,xml]
-       dev-perl/DBD-Pg
-       dev-perl/DBI
-       dev-perl/YAML
-       >=dev-php/awl-0.60
-       virtual/httpd-php"
-
-need_httpd
-
-S="${WORKDIR}"
-
-src_compile() {
-       emake built-locale
-}
-
-src_install() {
-       webapp_src_preinst
-
-       einstalldocs
-
-       einfo "Installing web files"
-       insinto "${MY_HTDOCSDIR}"
-       doins -r htdocs/. htdocs/.htaccess
-
-       einfo "Installing main files and i18n"
-       insinto "${MY_HOSTROOTDIR}/${PN}"
-       doins -r inc locale
-       rm "${ED}/${MY_HOSTROOTDIR}/${PN}/inc/always.php.in" || die
-
-       einfo "Installing sql files"
-       insinto "${MY_SQLSCRIPTSDIR}"
-       doins -r dba/.
-
-       insinto /etc/${PN}
-       doins -r config/. "${FILESDIR}/vhost-example"
-
-       webapp_postinst_txt en "${FILESDIR}/postinstall-en.txt"
-       webapp_postupgrade_txt en "${FILESDIR}/postupgrade-en.txt"
-       webapp_src_install
-
-       fperms +x "${MY_SQLSCRIPTSDIR}/create-database.sh"
-       fperms +x "${MY_SQLSCRIPTSDIR}/update-davical-database"
-}
-
-pkg_postinst() {
-       elog "If you are upgrading from a previous version of davical, don't forget to"
-       elog "upgrade the database structure with"
-       elog "       cd /usr/share/webapps/davical/${PVR}/sqlscripts/"
-       elog "       ./update-davical-database -dbuser xxxxxxx -appuser xxxxxx"
-
-       webapp_pkg_postinst
-}
diff --git a/www-apps/davical/files/davical-1.1.7-fix_php4_style_constructors.patch b/www-apps/davical/files/davical-1.1.7-fix_php4_style_constructors.patch
deleted file mode 100644 (file)
index a236e28..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
-diff --git a/inc/HTTPAuthSession.php b/inc/HTTPAuthSession.php
-index e3b208c6..08663286 100644
---- a/inc/HTTPAuthSession.php
-+++ b/inc/HTTPAuthSession.php
-@@ -60,7 +60,7 @@ class HTTPAuthSession {
-   /**
-   * The constructor, which just calls the type supplied or configured
-   */
--  function HTTPAuthSession() {
-+  function __construct() {
-     global $c;
-     if ( ! empty($_SERVER['PHP_AUTH_DIGEST'])) {
-diff --git a/inc/PublicSession.php b/inc/PublicSession.php
-index 28e06173..e779a9df 100644
---- a/inc/PublicSession.php
-+++ b/inc/PublicSession.php
-@@ -59,7 +59,7 @@ class PublicSession {
-   /**
-   * The constructor, which just calls the actual type configured
-   */
--  function PublicSession() {
-+  function __construct() {
-     global $c;
-     $principal = new Principal('username','unauthenticated');
-diff --git a/inc/caldav-client.php b/inc/caldav-client.php
-index 4c1bf67f..b32c5c91 100644
---- a/inc/caldav-client.php
-+++ b/inc/caldav-client.php
-@@ -48,7 +48,7 @@ class CalDAVClient {
-   * @param string $pass      The password for that user
-   * @param string $calendar  The name of the calendar (not currently used)
-   */
--  function CalDAVClient( $base_url, $user, $pass, $calendar = '' ) {
-+  function __construct( $base_url, $user, $pass, $calendar = '' ) {
-     $this->user = $user;
-     $this->pass = $pass;
-     $this->calendar = $calendar;