media-libs/opencv: Permit numpy-python2 in 2*
authorMichał Górny <mgorny@gentoo.org>
Thu, 30 Jan 2020 21:16:55 +0000 (22:16 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 30 Jan 2020 21:26:12 +0000 (22:26 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
media-libs/opencv/opencv-2.4.13-r3.ebuild

index d4379a93e73cb2262bf113172c670180d880ebb5..caceec0fd66e478c77a171d2739f09fdcd466f60 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -51,7 +51,13 @@ RDEPEND="
        openexr? ( media-libs/openexr )
        opengl? ( virtual/opengl virtual/glu )
        png? ( media-libs/libpng:0= )
-       python? ( ${PYTHON_DEPS} dev-python/numpy[${PYTHON_USEDEP}] )
+       python? (
+               ${PYTHON_DEPS}
+               || (
+                       dev-python/numpy-python2[${PYTHON_USEDEP}]
+                       dev-python/numpy[${PYTHON_USEDEP}]
+               )
+       )
        qt5? (
                dev-qt/qtconcurrent:5
                dev-qt/qtcore:5