dev-python/pyclipper: Remove extraneous deps
authorMichał Górny <mgorny@gentoo.org>
Fri, 29 May 2020 16:27:09 +0000 (18:27 +0200)
committerMichał Górny <mgorny@gentoo.org>
Fri, 29 May 2020 16:27:09 +0000 (18:27 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pyclipper/pyclipper-1.1.0_p3-r1.ebuild

index 728a3586492bfe6ae595ce4524151aede37a5ec4..0b3f303ecd9cbca346d63442b7bac053adf3daf8 100644 (file)
@@ -9,6 +9,7 @@ inherit distutils-r1
 DESCRIPTION="Cython wrapper for the C++ translation of the Angus Johnson's Clipper library"
 HOMEPAGE="https://github.com/fonttools/pyclipper"
 SRC_URI="https://github.com/fonttools/pyclipper/archive/${PV/_p/.post}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P/_p/.post}"
 
 LICENSE="MIT"
 SLOT="0"
@@ -17,21 +18,14 @@ IUSE=""
 
 BDEPEND="
        dev-python/cython[${PYTHON_USEDEP}]
-       dev-python/setuptools-git[${PYTHON_USEDEP}]
        dev-python/setuptools_scm[${PYTHON_USEDEP}]
-       dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
        test? (
-               dev-python/pytest-runner[${PYTHON_USEDEP}]
                dev-python/unittest2[${PYTHON_USEDEP}]
        )
 "
-RDEPEND=""
-DEPEND=""
 
 distutils_enable_tests pytest
 
-S="${WORKDIR}/${P/_p/.post}"
-
 src_prepare() {
        distutils-r1_src_prepare
        export SETUPTOOLS_SCM_PRETEND_VERSION="${PV/_p/.post}"