app-misc/gramps: work around problems with --skip-build
authorMarek Szuba <marecki@gentoo.org>
Tue, 21 Apr 2020 22:14:27 +0000 (23:14 +0100)
committerMarek Szuba <marecki@gentoo.org>
Tue, 21 Apr 2020 22:20:48 +0000 (23:20 +0100)
Required to make new Gramps installations work following one of the
recent changes to distutils-r1.eclass (commit
180fa85d7d00aea463c399f70348beaad9166eb7). Has the dubious distinction
of being possibly the ugliest hack I have ever had to implement.

Bug: https://bugs.gentoo.org/717922
Signed-off-by: Marek Szuba <marecki@gentoo.org>
app-misc/gramps/gramps-5.1.2-r1.ebuild

index c13785854d7dc69d9e96530b744dfdbde59f96bc..3144f1370d3deedb5d60287d500bfd447381f887 100644 (file)
@@ -63,6 +63,17 @@ python_test_all() {
        esetup.py test
 }
 
+# Ugly hack to work around Bug #717922
+python_install() {
+       local mydistutilsargs=(
+               --resourcepath=/usr/share
+               --no-compress-manpages
+               build
+       )
+       distutils-r1_python_install
+       echo -n "/usr/share" > "${D}$(python_get_sitedir)/gramps/gen/utils/resource-path" || die
+}
+
 pkg_postinst() {
        xdg_desktop_database_update
        xdg_mimeinfo_database_update