dev-libs/icu-layoutex: Drop 58.2
authorAndreas Sturmlechner <asturm@gentoo.org>
Thu, 27 Jun 2019 09:13:43 +0000 (11:13 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Thu, 27 Jun 2019 10:47:26 +0000 (12:47 +0200)
Package-Manager: Portage-2.3.67, Repoman-2.3.16
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-libs/icu-layoutex/Manifest
dev-libs/icu-layoutex/icu-layoutex-58.2.ebuild [deleted file]

index efaf4e9e5150c24c8f4906fd8aefe9350317b647..8e3d05e0d4d05c375fe879f5e598fd0da874b151 100644 (file)
@@ -1,2 +1 @@
-DIST icu4c-58_2-src.tgz 23369902 BLAKE2B cdd2e02c3aba050f5b7f8b38c5a3731e3e5f1cc1403ef86a50908b95560ea3cf8a2d47119fa60cf34f22a8b65eaa2392fd5bcbd3bc48b3da541fe3d9bd7392c0 SHA512 5c21af748f48b392e6c0412bd0aee92162ea931820dcbfab4ec6e0299868504b303d88f7586cc95de55c777ac0dca3a29d6c8ca0892c646ebc864c8a5b5a162a
 DIST icu4c-64_2-src.tgz 24013250 BLAKE2B 4a286e7a952f5faa74d942f6b6a73147a46aa10fe6d54d024e2d18d1e01056444d56118ded04b4fe084d6a0f9058d7d9e76973960ac8fe5bd9ee105d9e214318 SHA512 5ecb4c230ba45918747a1cf9aef86f555aa07d5b29b1d07ab674e8013f46dfb907a0e9d6945db41155f9dc3012fd94e1152ffc19f61a68b6dfcbabdcb8ae9d78
diff --git a/dev-libs/icu-layoutex/icu-layoutex-58.2.ebuild b/dev-libs/icu-layoutex/icu-layoutex-58.2.ebuild
deleted file mode 100644 (file)
index 92aedc3..0000000
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils flag-o-matic toolchain-funcs autotools multilib-minimal
-
-DESCRIPTION="External layout part of International Components for Unicode"
-HOMEPAGE="http://www.icu-project.org/"
-SRC_URI="http://download.icu-project.org/files/icu4c/${PV/_/}/icu4c-${PV//./_}-src.tgz"
-
-LICENSE="BSD"
-
-SLOT="0/${PV}"
-
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 x86"
-IUSE="debug static-libs"
-
-RDEPEND="
-       ~dev-libs/icu-${PV}[${MULTILIB_USEDEP}]
-       dev-libs/icu-le-hb[${MULTILIB_USEDEP}]
-"
-
-DEPEND="
-       virtual/pkgconfig[${MULTILIB_USEDEP}]
-       ${RDEPEND}
-"
-
-S="${WORKDIR}/${PN/-layoutex}/source"
-
-PATCHES=(
-       "${FILESDIR}/${PN}-58.1-remove-bashisms.patch"
-)
-
-src_prepare() {
-       # apply patches
-       default
-
-       local variable
-
-       # Disable renaming as it is stupid thing to do
-       sed -i \
-               -e "s/#define U_DISABLE_RENAMING 0/#define U_DISABLE_RENAMING 1/" \
-               common/unicode/uconfig.h || die
-
-       # Fix linking of icudata
-       sed -i \
-               -e "s:LDFLAGSICUDT=-nodefaultlibs -nostdlib:LDFLAGSICUDT=:" \
-               config/mh-linux || die
-
-       eautoreconf
-}
-
-src_configure() {
-       # Use C++14
-       append-cxxflags -std=c++14
-
-       if tc-is-cross-compiler; then
-               mkdir "${WORKDIR}"/host || die
-               pushd "${WORKDIR}"/host >/dev/null || die
-
-               CFLAGS="" CXXFLAGS="" ASFLAGS="" LDFLAGS="" \
-               CC="$(tc-getBUILD_CC)" CXX="$(tc-getBUILD_CXX)" AR="$(tc-getBUILD_AR)" \
-               RANLIB="$(tc-getBUILD_RANLIB)" LD="$(tc-getBUILD_LD)" \
-               "${S}"/configure --disable-renaming --disable-debug \
-                       --disable-samples --enable-static || die
-               emake
-
-               popd >/dev/null || die
-       fi
-
-       multilib-minimal_src_configure
-}
-
-multilib_src_configure() {
-       local myeconfargs=(
-               --disable-renaming
-               --disable-samples
-               --enable-layoutex
-               $(use_enable debug)
-               $(use_enable static-libs static)
-       )
-
-       tc-is-cross-compiler && myeconfargs+=(
-               --with-cross-build="${WORKDIR}"/host
-       )
-
-       # icu tries to use clang by default
-       tc-export CC CXX
-
-       ECONF_SOURCE=${S} \
-       econf "${myeconfargs[@]}"
-}
-
-multilib_src_test() {
-       # INTLTEST_OPTS: intltest options
-       #   -e: Exhaustive testing
-       #   -l: Reporting of memory leaks
-       #   -v: Increased verbosity
-       # IOTEST_OPTS: iotest options
-       #   -e: Exhaustive testing
-       #   -v: Increased verbosity
-       # CINTLTST_OPTS: cintltst options
-       #   -e: Exhaustive testing
-       #   -v: Increased verbosity
-       pushd layoutex &>/dev/null || die
-       emake -j1 VERBOSE="1" check
-       popd &>/dev/null || die
-}
-
-multilib_src_install() {
-       pushd layoutex &>/dev/null || die
-       default
-       popd &>/dev/null || die
-}