x11-libs/libXi: Version bump to 1.7.10
authorMatt Turner <mattst88@gentoo.org>
Wed, 19 Jun 2019 16:49:36 +0000 (12:49 -0400)
committerMatt Turner <mattst88@gentoo.org>
Wed, 19 Jun 2019 16:52:47 +0000 (12:52 -0400)
Signed-off-by: Matt Turner <mattst88@gentoo.org>
x11-libs/libXi/Manifest
x11-libs/libXi/libXi-1.7.10.ebuild [new file with mode: 0644]

index dbe21c24806f8c304447a38bf5d0f4e3f154c46d..53f205d0ca45d5d51214d423201bd26711bde577 100644 (file)
@@ -1 +1,2 @@
+DIST libXi-1.7.10.tar.bz2 484519 BLAKE2B b4a3a090045d65c351d21a65fdf2f3d252e11546a5eaba9bf5f22c837b84ee758fe325eff39b32df55f65ab3d6cdc0d2c7ac7e134fec0983baeb0103d109c810 SHA512 591f0860bf5904897587c4990d6c852f3729a212d1ef390362d41242440e078221877c31db2232d5cc81727fe97f4e194b077f7de917e251e60641bbd06ee218
 DIST libXi-1.7.9.tar.bz2 486312 BLAKE2B 2dae307168431ed0a629ee1be1fa0f93732105452be822bc9cf54cc0863286306c2bdda67c16bb7ed92d63d669f884a4a67ae67ffcc7c170f91848039d470c0b SHA512 9f1536944fcd232ba725addbc3afb1154c4e0df3c4380f4a54bada31371029ce3714fe0458529cd6b2787e3283f3bd35366420bca15fedfbd41f2f6b10eddce5
diff --git a/x11-libs/libXi/libXi-1.7.10.ebuild b/x11-libs/libXi/libXi-1.7.10.ebuild
new file mode 100644 (file)
index 0000000..30970c5
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit xorg-3
+
+DESCRIPTION="X.Org Xi library"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE=""
+
+RDEPEND="
+       >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+       >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+       >=x11-libs/libXfixes-5.0.1[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+       x11-base/xorg-proto"
+
+pkg_setup() {
+       XORG_CONFIGURE_OPTIONS=(
+               $(use_enable doc specs)
+               $(use_with doc xmlto)
+               $(use_with doc asciidoc)
+               --without-fop
+       )
+}