dev-python/secretstorage: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Sun, 29 Mar 2020 07:48:05 +0000 (09:48 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 29 Mar 2020 08:18:51 +0000 (10:18 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/secretstorage/Manifest
dev-python/secretstorage/secretstorage-2.3.1.ebuild [deleted file]
dev-python/secretstorage/secretstorage-3.1.0.ebuild [deleted file]

index d3d0e07edadc8114ef6b301c8668f6f8fc5702e1..2dc629297e549a2279b1adc66651b96ee2243db7 100644 (file)
@@ -1,3 +1 @@
-DIST SecretStorage-2.3.1.tar.gz 16073 BLAKE2B e4769e748ee39596c51012a6ac626dba2b019238a8237678c47d713c2af4b0e88b50d0068b5dbf3a405b9f7b14a7df64aabf751009dd21ab25de65ead2a79c38 SHA512 69a2c86a1abd904b7d71bbb59cead3b2588cf88d7f35cbaf64d18ff9aa9ed62ba9f79d0bebd10136aa8a0edb1ff8a1d1aff70cf8e519dc74303993ef0d564047
-DIST SecretStorage-3.1.0.tar.gz 17767 BLAKE2B e234a7f34b5ca2debfd04d4f3b4b4e2a1625aa346133e464bbc1f094381445e3d0c5460457c687f55f6682c6b6085a757edb23a6029fe5c2abf139278203f326 SHA512 a044009480b359aecb0c8782f04e4d02c3c1c0e682f72733896c98f386562c43766318963452d60028d0a92d02903130278cf26a5c206f5f0909e106bdb2d133
 DIST SecretStorage-3.1.1.tar.gz 17036 BLAKE2B 1dda10a5f74727ec29392ff2a3ec65b841aff86db21223ebdbf291afcc9ac7ee68de8c62e5929aa45aafabc791ac02ed80b6785e69f2d4b51d827fce8bbb3443 SHA512 295e0f75c772edf153480730dc20051f06e60e040a18f169620cb4aaa37b8c1a254a496464d3794a38cf49fa884a7b561fe364816f0d12a5b2622c77259f03cf
diff --git a/dev-python/secretstorage/secretstorage-2.3.1.ebuild b/dev-python/secretstorage/secretstorage-2.3.1.ebuild
deleted file mode 100644 (file)
index 43765fc..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{3_6,3_7} )
-
-inherit distutils-r1
-
-MY_PN="SecretStorage"
-
-DESCRIPTION="Python bindings to FreeDesktop.org Secret Service API."
-HOMEPAGE="https://github.com/mitya57/secretstorage https://pypi.org/project/SecretStorage/"
-SRC_URI="mirror://pypi/S/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-RDEPEND="
-       dev-python/cryptography[${PYTHON_USEDEP}]
-       dev-python/dbus-python[${PYTHON_USEDEP}]"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
diff --git a/dev-python/secretstorage/secretstorage-3.1.0.ebuild b/dev-python/secretstorage/secretstorage-3.1.0.ebuild
deleted file mode 100644 (file)
index 45d4986..0000000
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{6,7} )
-
-inherit distutils-r1
-
-MY_PN="SecretStorage"
-
-DESCRIPTION="Python bindings to FreeDesktop.org Secret Service API."
-HOMEPAGE="https://github.com/mitya57/secretstorage https://pypi.org/project/SecretStorage/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       dev-python/cryptography[${PYTHON_USEDEP}]
-       dev-python/jeepney[${PYTHON_USEDEP}]
-"
-BDEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? (
-               dev-python/sphinx[${PYTHON_USEDEP}]
-               dev-python/alabaster[${PYTHON_USEDEP}]
-       )
-       test? ( ${RDEPEND} )
-"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_compile_all() {
-       if use doc; then
-               sphinx-build docs docs/_build/html || die
-               HTML_DOCS=( docs/_build/html/. )
-       fi
-}
-
-python_test() {
-       dbus-run-session "${EPYTHON}" -m unittest discover -v -s tests \
-               || die "tests failed with ${EPYTHON}"
-}