sci-visualization/paraview: Fix compilation with protobuf-2.6 (bug #537988)
authorMatthias Maier <tamiko@gentoo.org>
Sun, 20 Sep 2015 02:53:17 +0000 (21:53 -0500)
committerMatthias Maier <tamiko@gentoo.org>
Sun, 20 Sep 2015 03:04:08 +0000 (22:04 -0500)
Gentoo-Bug: 537988

Package-Manager: portage-2.2.20.1

sci-visualization/paraview/files/paraview-4.3.1-protobuf-2.6.patch [moved from sci-visualization/paraview/files/paraview-4.2.0-protobuf-2.patch with 84% similarity]
sci-visualization/paraview/paraview-4.2.0-r1.ebuild
sci-visualization/paraview/paraview-4.3.1.ebuild

similarity index 84%
rename from sci-visualization/paraview/files/paraview-4.2.0-protobuf-2.patch
rename to sci-visualization/paraview/files/paraview-4.3.1-protobuf-2.6.patch
index f1ea7b5b01bca1f36b9fdc52562a2a40e6139efd..5a7871f0790de05ed1f9003f436dcc6e57842598 100644 (file)
@@ -1,5 +1,11 @@
-diff --git a/ParaViewCore/ServerImplementation/Core/vtkPVMessage.proto b/ParaViewCore/ServerImplementation/Core/vtkPVMessage.proto
-index 60e084c..aed5832 100644
+https://gitlab.kitware.com/ben.boeckel/paraview/commit/40a62e0bd20ceb73d7a545dab73e975fa07cddbb
+http://www.vtk.org/Bug/view.php?id=15442#c34997
+
+https://bugs.gentoo.org/show_bug.cgi?id=537988
+
+This updates the *.proto files to be compatible with version 2.6 and fixes
+a bug that prevented successful compilation with protobuf 2.6.
+
 --- a/ParaViewCore/ServerImplementation/Core/vtkPVMessage.proto
 +++ b/ParaViewCore/ServerImplementation/Core/vtkPVMessage.proto
 @@ -21,7 +21,7 @@ message Variant {
@@ -159,3 +165,13 @@ index 60e084c..aed5832 100644
    }
  }
  
+--- a/ParaViewCore/ServerManager/Rendering/vtkSMCameraLink.cxx
++++ b/ParaViewCore/ServerManager/Rendering/vtkSMCameraLink.cxx
+@@ -363,6 +363,6 @@ void vtkSMCameraLink::LoadState(const vtkSMMessage *msg, vtkSMProxyLocator *loca
+ void vtkSMCameraLink::UpdateState()
+ {
+   this->Superclass::UpdateState();
+-  this->State->GetExtension(LinkState::sync_interactive_renders,
++  this->State->SetExtension(LinkState::sync_interactive_renders,
+     this->GetSynchronizeInteractiveRenders());
+ }
index 62bbc1f8814b96ef706da5c028d41dd239d76c82..7777925a4ac4526baa3ca944afea5f955a926191 100644 (file)
@@ -92,7 +92,6 @@ src_prepare() {
                "${FILESDIR}"/${P}-removesqlite.patch \
                "${FILESDIR}"/${PN}-4.0.1-gcc-4.7.patch \
                "${FILESDIR}"/${P}-protobuf.patch \
-               "${FILESDIR}"/${P}-protobuf-2.patch \
                "${FILESDIR}"/${PN}-4.1.0-no-fatal-warnings.patch \
                "${FILESDIR}"/${P}-vtk-freetype.patch
 
index bba20916be9aae8e6806b0e446b7118219466281..7d7b44fc04e6bbed084b67070233f2699d6c0c68 100644 (file)
@@ -29,7 +29,7 @@ RDEPEND="
        dev-libs/expat
        >=dev-libs/jsoncpp-0.10.1
        dev-libs/libxml2:2
-       <dev-libs/protobuf-2.6
+       dev-libs/protobuf
        media-libs/freetype
        media-libs/libpng:0
        media-libs/libtheora
@@ -93,7 +93,7 @@ src_prepare() {
                "${FILESDIR}"/${PN}-4.2.0-removesqlite.patch \
                "${FILESDIR}"/${PN}-4.0.1-gcc-4.7.patch \
                "${FILESDIR}"/${PN}-4.2.0-protobuf.patch \
-               "${FILESDIR}"/${PN}-4.2.0-protobuf-2.patch \
+               "${FILESDIR}"/${P}-protobuf-2.6.patch \
                "${FILESDIR}"/${PN}-4.1.0-no-fatal-warnings.patch \
                "${FILESDIR}"/${PN}-4.2.0-vtk-freetype.patch