Security fix and version bump, bug 161278
authorSteve Dibb <beandog@gentoo.org>
Wed, 17 Jan 2007 03:53:28 +0000 (03:53 +0000)
committerSteve Dibb <beandog@gentoo.org>
Wed, 17 Jan 2007 03:53:28 +0000 (03:53 +0000)
Package-Manager: portage-2.1.1-r2

www-apps/wordpress/ChangeLog
www-apps/wordpress/files/digest-wordpress-2.0.7 [new file with mode: 0644]
www-apps/wordpress/wordpress-2.0.7.ebuild [new file with mode: 0644]

index 4a51657de10ceb556acd2d12baec48ba6160fcd7..229187aa3ef02df9dd8cf4c65a12f38f1ce722b2 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for www-apps/wordpress
 # Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/wordpress/ChangeLog,v 1.68 2007/01/05 17:19:05 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/wordpress/ChangeLog,v 1.69 2007/01/17 03:53:27 beandog Exp $
+
+*wordpress-2.0.7 (17 Jan 2007)
+
+  17 Jan 2007; Steve Dibb <beandog@gentoo.org> -wordpress-2.0.6.ebuild,
+  +wordpress-2.0.7.ebuild:
+  Security fix and version bump, bug 161278
 
 *wordpress-2.0.6 (05 Jan 2007)
 
diff --git a/www-apps/wordpress/files/digest-wordpress-2.0.7 b/www-apps/wordpress/files/digest-wordpress-2.0.7
new file mode 100644 (file)
index 0000000..98eabec
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 e377fa9389d1a06a700ac349582f498c wordpress-2.0.7.tar.gz 519033
+RMD160 33eef00c3bd7ccc486402ae1678acbf9531a8b26 wordpress-2.0.7.tar.gz 519033
+SHA256 ae5521a3597f76e01c084a28bdbb70cd8fc7c7a40e91983f70887bff58aead0a wordpress-2.0.7.tar.gz 519033
diff --git a/www-apps/wordpress/wordpress-2.0.7.ebuild b/www-apps/wordpress/wordpress-2.0.7.ebuild
new file mode 100644 (file)
index 0000000..4a4e02c
--- /dev/null
@@ -0,0 +1,90 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/wordpress/wordpress-2.0.7.ebuild,v 1.1 2007/01/17 03:53:28 beandog Exp $
+
+inherit webapp eutils
+
+#Wordpress releases have a release name tagged on the end of the version on the tar.gz files
+#MY_EXT="mingus"
+
+DESCRIPTION="Wordpress php and mysql based CMS system."
+HOMEPAGE="http://wordpress.org/"
+#Latest version is only available in the format!
+#Download is renamed by HTTP Header as wordpress-<version number>.tar.gz
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="amd64 hppa ppc sparc x86"
+IUSE=""
+RDEPEND="virtual/httpd-php
+        virtual/mysql"
+
+DEPEND="${DEPEND} ${RDEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+       local docs="license.txt readme.html"
+
+       webapp_src_preinst
+
+       einfo "Installing main files"
+       cp wp-config-sample.php wp-config.php
+       cp -r * ${D}${MY_HTDOCSDIR}
+       einfo "Done"
+
+       ewarn
+       ewarn Please make sure you have register_globals = off set in your /etc/apache2/php.ini file
+       ewarn If this is not an option for your web server and you NEED it set to on, then insert the following in your WordPress .htaccess file:
+       ewarn php_flag register_globals off
+       ewarn
+
+       ewarn
+       ewarn You will need to create a table for your WordPress database.  This
+       ewarn assumes you have some knowledge of MySQL, and already have it
+       ewarn installed and configured.  If not, please refer to
+       ewarn the Gentoo MySQL guide at the following URL:
+       ewarn http://www.gentoo.org/doc/en/mysql-howto.xml
+       ewarn Log in to MySQL, and create a new database called
+       ewarn "wordpress". From this point, you will need to edit
+       ewarn your wp-config.php file in $DocumentRoot/wordpress/
+       ewarn and point to your database. Once this is done, you can log in to
+       ewarn WordPress at http://localhost/wordpress
+       ewarn
+
+       ewarn
+       ewarn If you are upgrading from a previous version BACK UP your
+       ewarn database.  Once you are done with that, browse to
+       ewarn http://localhost/wordpress/wp-admin/upgrade.php and follow
+       ewarn the instructions on the screen.
+       ewarn
+
+       # handle documentation files
+       #
+       # NOTE that doc files go into /usr/share/doc as normal; they do NOT
+       # get installed per vhost!
+
+       dodoc ${docs}
+       for doc in ${docs} INSTALL; do
+               rm -f ${doc}
+       done
+
+       # Identify the configuration files that this app uses
+       # User can want to make changes to these!
+       webapp_serverowned ${MY_HTDOCSDIR}/index.php
+       #webapp_serverowned ${MY_HTDOCSDIR}/wp-layout.css
+       webapp_serverowned ${MY_HTDOCSDIR}/wp-admin/menu.php
+       webapp_serverowned ${MY_HTDOCSDIR}
+       webapp_configfile  ${MY_HTDOCSDIR}/wp-config.php
+       # Identify any script files that need #! headers adding to run under
+       # a CGI script (such as PHP/CGI)
+       #
+       # for wordpress, we *assume* that all .php files need to have CGI/BIN
+       # support added
+
+       # post-install instructions
+       #webapp_postinst_txt en ${FILESDIR}/1.2/postinstall-en.txt
+
+       # now strut stuff
+       webapp_src_install
+
+}