sci-libs/cantera: add support sci-libs/sundials-5.0, dev-lang/python-3.8
authorband-a-prend <torokhov-s-a@yandex.ru>
Thu, 26 Dec 2019 15:01:30 +0000 (18:01 +0300)
committerJoonas Niilola <juippis@gentoo.org>
Mon, 6 Jan 2020 15:40:08 +0000 (17:40 +0200)
Simple fix for Sundials-5.0 and Python-3.8 compatibility.
The Sundials-5.0 has the same API as Sundials-4.x for CVODES function.

Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru>
Closes: https://github.com/gentoo/gentoo/pull/14126
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
sci-libs/cantera/cantera-2.4.0-r2.ebuild
sci-libs/cantera/files/cantera_2.4.0_sundials4.patch

index 57b648726246f8dee2b1d06bcabd0357633e302a..79b1572e51c8e5cf3e693209ec20d7aa2d0e52b2 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
 
 FORTRAN_NEEDED=fortran
 FORTRAN_STANDARD=90
@@ -30,7 +30,7 @@ RDEPEND="
        python? (
                dev-python/numpy[${PYTHON_USEDEP}]
        )
-       <sci-libs/sundials-5.0.0:0=
+       <sci-libs/sundials-5.1.0:0=
 "
 
 DEPEND="
index c745f6b6f7ff8d100c49d7d0c32d24bb8e8f2989..0345a98e252778cd9b089c2306e7ffb036d0c2aa 100644 (file)
@@ -47,7 +47,7 @@ diff -Nur old/SConstruct new/SConstruct
      # Ignore the minor version, e.g. 2.4.x -> 2.4
      env['sundials_version'] = '.'.join(sundials_version.split('.')[:2])
 -    if env['sundials_version'] not in ('2.4','2.5','2.6','2.7','3.0','3.1','3.2'):
-+    if env['sundials_version'] not in ('2.4','2.5','2.6','2.7','3.0','3.1','3.2','4.0','4.1'):
++    if env['sundials_version'] not in ('2.4','2.5','2.6','2.7','3.0','3.1','3.2','4.0','4.1','5.0'):
          print("""ERROR: Sundials version %r is not supported.""" % env['sundials_version'])
          sys.exit(1)
      print("""INFO: Using system installation of Sundials version %s.""" % sundials_version)