app-admin/restart-services: added new version 0.14.2
authorMarc Schiffbauer <mschiff@gentoo.org>
Mon, 19 Nov 2018 10:24:09 +0000 (11:24 +0100)
committerMarc Schiffbauer <mschiff@gentoo.org>
Mon, 19 Nov 2018 10:24:09 +0000 (11:24 +0100)
Signed-off-by: Marc Schiffbauer <mschiff@gentoo.org>
Package-Manager: Portage-2.3.49, Repoman-2.3.10

app-admin/restart-services/Manifest
app-admin/restart-services/restart-services-0.14.2.ebuild [new file with mode: 0644]

index d16676e600979ff09eda6bab29b2852c7b614192..64aecb66d245a898133b70974e5ea79b5fbe7a99 100644 (file)
@@ -1 +1,2 @@
 DIST restart-services-0.14.1.tgz 20909 BLAKE2B 2f6b74fc6094be83e1872d2a6ca7abb02a49b5db65d81cd37f8161bac148e5fe0614502f1f06356ff9cd6c6ba03c416dae1eec3a86f48dc011bc6e28c1b076e3 SHA512 3434c4b6cdf9d02b035eba2cc67cebe8e06a2cf31c2d8627063b84224dcb6d44e276e1fcb82221ad77ab7ee7e16fa7ee58fb94b7849d40e6786d3fcfb6087866
+DIST restart-services-0.14.2.tgz 21227 BLAKE2B 9a3f03bbd1995df6f583f8c4228914f098922828b1407c0c8069908ebdbef67599a8a7421b0c404adf2d330632ae83646300a965c514f6746bbd95674ab102ea SHA512 487e8d0a448954be7b79d1c95bffd00d5f875ccb908b8004e18e45752e593fe57713f97c0749e28367bf7606c5cf46556f31de6b018a151f7cd384c88277ca7c
diff --git a/app-admin/restart-services/restart-services-0.14.2.ebuild b/app-admin/restart-services/restart-services-0.14.2.ebuild
new file mode 100644 (file)
index 0000000..86a6e7c
--- /dev/null
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Tool to manage OpenRC services that need to be restarted"
+HOMEPAGE="https://dev.gentoo.org/~mschiff/restart-services/"
+SRC_URI="https://dev.gentoo.org/~mschiff/src/${PN}/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+       app-admin/lib_users
+       sys-apps/openrc
+"
+
+src_install() {
+       dosbin restart-services
+       doman restart-services.1
+       keepdir /etc/restart-services.d
+       insinto /etc
+       doins restart-services.conf
+       dodoc README CHANGES
+
+       sed -i 's/^#include/include/' "${D}"/etc/restart-services.conf
+       cat>"${D}"/etc/restart-services.d/00-local.conf<<-EOF
+       # You may put your local changes here or in any other *.conf file
+       # in this directory so you can leave /etc/restart-services.conf as is.
+       # Example:
+       # *extend* SV_ALWAYS to match 'myservice'
+       # SV_ALWAYS+=( myservice )
+       EOF
+}
+
+pkg_postinst() {
+       local MAJOR MINOR
+       # migrate config data for versions < 0.13.2
+       if [[ $REPLACING_VERSIONS ]]; then
+               MAJOR=${REPLACING_VERSIONS%%.*}
+               MINOR=${REPLACING_VERSIONS%.*}
+               MINOR=${MINOR#*.}
+
+               if [[ $MAJOR -eq 0 && $MINOR -lt 14 ]]; then
+                       einfo "Checking for old config"
+                       if [[ -f /etc/restart_services.conf ]]; then
+                               ewarn "Old config file found: /etc/restart_services.conf"
+                               ewarn "It will be ignored so please migrate settings to a file in"
+                               ewarn "/etc/restart-services.d/ and/or remove /etc/restart_services.conf"
+                       fi
+                       if [[ -d /etc/restart_services.d ]]; then
+                               ewarn "Old config directory found: /etc/restart_services.d"
+                               ewarn "It will be ignored so please migrate files to /etc/restart-services.d"
+                               ewarn "and/or remove /etc/restart_services.d"
+                       fi
+                       einfo "done"
+               fi
+       fi
+}