app-text/libgxps: Version bump
authorPacho Ramos <pacho@gentoo.org>
Sat, 5 Sep 2015 12:33:40 +0000 (14:33 +0200)
committerPacho Ramos <pacho@gentoo.org>
Sat, 5 Sep 2015 12:33:40 +0000 (14:33 +0200)
Package-Manager: portage-2.2.20.1

app-text/libgxps/Manifest
app-text/libgxps/libgxps-0.2.3.2.ebuild [new file with mode: 0644]

index 77a1d4aabd3d57ab1a6785140dbeecee74ca4e0b..048788e6324556d84892683a0e3013fb1a5981b8 100644 (file)
@@ -1 +1,2 @@
 DIST libgxps-0.2.2.tar.xz 302844 SHA256 39d104739bf0db43905c315de1d8002460f1a098576f4418f69294013a5820be SHA512 96fa462cb4bba9cdba3d8cfe416199f8d956d17397e3514aa6168c7acc865a30e9347d8f9850f16a8c2a0a83dc83f7d7d2bd1806e27a2af0914ce53fed2b4467 WHIRLPOOL cc4aeb94d3c989bb8dfc7b4912a1c8d86f46d8cef0051657d7cbdb9d565aaf0d07e65619f643246bc5abd7010e40046cd683ba36a8fa261eb3762bb8ee795b5a
+DIST libgxps-0.2.3.2.tar.xz 323060 SHA256 6ea5f0ed85665a4e6702e31e38b5f1b2e5ae4f3d316a55d7f1fb1799224b4127 SHA512 fc1f8f1a3091efaa60f29a1842e997ed72c9888b8d903b613dd0073468172a8e2d757877207ab81b155fcb3988ec975c91490c20afb4ebae1e03e0e1cc620257 WHIRLPOOL d5069483f105ae1f4e4435c5b2fce18d7175a82354d59f311a0b8582d88a13695886870ef63772d7573dbaa1fdb3c1d68c2e975437d73ec4d24b2281033af399
diff --git a/app-text/libgxps/libgxps-0.2.3.2.ebuild b/app-text/libgxps/libgxps-0.2.3.2.ebuild
new file mode 100644 (file)
index 0000000..7c388c4
--- /dev/null
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GNOME2_LA_PUNT="yes"
+GCONF_DEBUG="yes"
+
+inherit gnome2
+
+DESCRIPTION="Library for handling and rendering XPS documents"
+HOMEPAGE="https://wiki.gnome.org/Projects/libgxps"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+introspection jpeg lcms static-libs tiff"
+
+RDEPEND="
+       >=app-arch/libarchive-2.8
+       >=dev-libs/glib-2.24:2
+       media-libs/freetype:2
+       media-libs/libpng:0
+       >=x11-libs/cairo-1.10[svg]
+       introspection? ( >=dev-libs/gobject-introspection-0.10.1:= )
+       jpeg? ( virtual/jpeg )
+       lcms? ( media-libs/lcms:2 )
+       tiff? ( media-libs/tiff[zlib] )
+"
+DEPEND="${RDEPEND}
+       app-text/docbook-xsl-stylesheets
+       dev-libs/libxslt
+       dev-util/gtk-doc-am
+       virtual/pkgconfig
+"
+
+# There is no automatic test suite, only an interactive test application
+RESTRICT="test"
+
+src_configure() {
+       gnome2_src_configure \
+               --enable-man \
+               --disable-test \
+               $(use_enable introspection) \
+               $(use_with jpeg libjpeg) \
+               $(use_with lcms liblcms2) \
+               $(use_enable static-libs static) \
+               $(use_with tiff libtiff)
+}