sys-apps/ibm-powerpc-utils: Add live ebuild
authorJeroen Roovers <jer@gentoo.org>
Thu, 6 Jun 2019 10:08:13 +0000 (12:08 +0200)
committerJeroen Roovers <jer@gentoo.org>
Thu, 6 Jun 2019 10:08:28 +0000 (12:08 +0200)
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
sys-apps/ibm-powerpc-utils/ibm-powerpc-utils-99999.ebuild [new file with mode: 0644]

diff --git a/sys-apps/ibm-powerpc-utils/ibm-powerpc-utils-99999.ebuild b/sys-apps/ibm-powerpc-utils/ibm-powerpc-utils-99999.ebuild
new file mode 100644 (file)
index 0000000..de8638e
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools git-r3
+
+DESCRIPTION="Utilities for the maintainance of the IBM and Apple PowerPC platforms"
+HOMEPAGE="https://github.com/ibm-power-utilities/powerpc-utils"
+EGIT_REPO_URI="${HOMEPAGE}"
+IUSE="+rtas"
+
+SLOT="0"
+LICENSE="IBM"
+KEYWORDS=""
+
+DEPEND="
+       sys-devel/bc
+"
+RDEPEND="
+       ${DEPEND}
+       !sys-apps/powerpc-utils
+       rtas? ( >=sys-libs/librtas-2.0.2 )
+"
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.3.5-docdir.patch
+)
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
+       econf $(use_with rtas librtas)
+}