dev-python/symengine: Raise minimum sci-libs/symengine to 0.5.0
authorAndreas Sturmlechner <asturm@gentoo.org>
Sun, 8 Mar 2020 14:52:00 +0000 (15:52 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 8 Mar 2020 16:01:28 +0000 (17:01 +0100)
Closes: https://bugs.gentoo.org/704092
Package-Manager: Portage-2.3.93, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-python/symengine/symengine-0.5.1-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/symengine/symengine-0.5.1-r1.ebuild b/dev-python/symengine/symengine-0.5.1-r1.ebuild
new file mode 100644 (file)
index 0000000..fe8498a
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+inherit distutils-r1
+
+MYP=${PN}.py-${PV}
+
+DESCRIPTION="Python wrappers to the symengine C++ library"
+HOMEPAGE="https://github.com/symengine/symengine.py"
+SRC_URI="https://github.com/symengine/symengine.py/archive/v${PV}.tar.gz -> ${MYP}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+RDEPEND="
+       dev-python/numpy[${PYTHON_USEDEP}]
+       >=sci-libs/symengine-0.5"
+DEPEND="${RDEPEND}
+       dev-python/cython[${PYTHON_USEDEP}]
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MYP}"
+
+python_test() {
+       cd "${BUILD_DIR}"
+       nosetests -v || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+       distutils-r1_python_prepare_all
+       rm "${ED}"/usr/share/doc/${PF}/README.md || die
+       newdoc README.md ${PN}.py.md
+}