dev-libs/softhsm: version bump
authorAlon Bar-Lev <alonbl@gentoo.org>
Thu, 10 May 2018 18:30:56 +0000 (21:30 +0300)
committerAlon Bar-Lev <alonbl@gentoo.org>
Thu, 10 May 2018 18:31:16 +0000 (21:31 +0300)
Package-Manager: Portage-2.3.24, Repoman-2.3.6

dev-libs/softhsm/Manifest
dev-libs/softhsm/softhsm-2.4.0.ebuild [new file with mode: 0644]

index c5b97747993c36ce7c5151839926059277a1f073..100a03a31732346a1f493a897b712c593fa0d5fb 100644 (file)
@@ -1 +1,2 @@
 DIST softhsm-2.3.0.tar.gz 992417 BLAKE2B dcb462a7d50be465c306e2208d2d446879ec093ce3a3233e338ba4df3b29a4f70050cd10ff513bff70ef37f98341230d061d48273a6fc54b668804311cb11bf8 SHA512 ef9ee41aa6eaeeb004d4ff5c78ca6e00895cc47e36551025a4422806eee8eead985cfd28476a867761a810f6957b0759edaac769bcdedf4ad974e426cfefce0f
+DIST softhsm-2.4.0.tar.gz 1042566 BLAKE2B 01a0f4bdc589847c4a1f860c3e3f572644d874b11d7ab8e149e598fc123b75e898de9a46f73f5f2a107edcaeabdda29e4b9b6d54af5b95ad79a3c7b7b77b8bbf SHA512 f14f65de32206500f708523ee88d8d5e3d1fd40175f1a9cd24c7760c829e2de9dbcb05453022df8186836c49a57e4eae7f2e75ce6a5346a426114f4d610a8a84
diff --git a/dev-libs/softhsm/softhsm-2.4.0.ebuild b/dev-libs/softhsm/softhsm-2.4.0.ebuild
new file mode 100644 (file)
index 0000000..419485d
--- /dev/null
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit ltprune
+
+DESCRIPTION="A software PKCS#11 implementation"
+HOMEPAGE="https://www.opendnssec.org/"
+SRC_URI="https://www.opendnssec.org/files/source/${P}.tar.gz"
+
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="bindist libressl migration-tool test"
+SLOT="2"
+LICENSE="BSD"
+
+RDEPEND="
+       sys-devel/gcc:=[cxx]
+       migration-tool? ( dev-db/sqlite:3 )
+       !libressl? ( dev-libs/openssl:=[bindist=] )
+       libressl? ( dev-libs/libressl )
+       !=dev-libs/softhsm-2.0.0:0
+"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+       test? ( dev-util/cppunit )
+"
+
+DOCS=(
+       NEWS
+       README.md
+)
+
+src_configure() {
+       econf \
+               --disable-static \
+               --localstatedir="${EROOT}var" \
+               --with-crypto-backend=openssl \
+               --disable-p11-kit \
+               $(use_enable !bindist ecc) \
+               $(use_enable !libressl gost) \
+               $(use_with migration-tool migrate)
+}
+
+src_install() {
+       default
+       keepdir "${EROOT}/var/lib/softhsm/tokens"
+       prune_libtool_files --modules
+}