dev-ros/gazebo_plugins: Initial import. Ebuild by me.
authorAlexis Ballier <aballier@gentoo.org>
Wed, 23 Sep 2015 12:29:57 +0000 (14:29 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Wed, 23 Sep 2015 12:29:57 +0000 (14:29 +0200)
Package-Manager: portage-2.2.21

dev-ros/gazebo_plugins/Manifest [new file with mode: 0644]
dev-ros/gazebo_plugins/gazebo_plugins-2.5.1.ebuild [new file with mode: 0644]
dev-ros/gazebo_plugins/gazebo_plugins-9999.ebuild [new file with mode: 0644]
dev-ros/gazebo_plugins/metadata.xml [new file with mode: 0644]

diff --git a/dev-ros/gazebo_plugins/Manifest b/dev-ros/gazebo_plugins/Manifest
new file mode 100644 (file)
index 0000000..29a1234
--- /dev/null
@@ -0,0 +1 @@
+DIST gazebo_ros_pkgs-2.5.1.tar.gz 1812295 SHA256 1d78839d174790db400466b4b165a79fea50177a3fbe59291539b8bdc1876d4e SHA512 2e0faaa770abe9ff2b41d176c7a3dadaf8749f32c924ba6018b3d7dabf0fe2a1e4ffd24c840c777229a4941e7f4522bf2287288619e2c819d4fb3c10fa431c9d WHIRLPOOL 09b0c5038b21a6cfc355fed8d8d2981cb845c8d209cb89112fb6daf1694b735dd68096ca7e2f255fdc2e8ba435080df186057344c81c2ac247c28d64019dbe32
diff --git a/dev-ros/gazebo_plugins/gazebo_plugins-2.5.1.ebuild b/dev-ros/gazebo_plugins/gazebo_plugins-2.5.1.ebuild
new file mode 100644 (file)
index 0000000..45c19f2
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-simulation/gazebo_ros_pkgs"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Robot-independent Gazebo plugins for sensors, motors and dynamic reconfigurable components"
+LICENSE="BSD Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/gazebo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/roscpp
+       dev-ros/rospy
+       dev-ros/nodelet
+       dev-ros/angles
+       dev-ros/std_srvs
+       dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+       dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/urdf
+       dev-ros/tf
+       dev-ros/tf2_ros
+       dev-ros/dynamic_reconfigure
+       dev-ros/driver_base
+       dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/trajectory_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/pcl_conversions
+       dev-ros/image_transport
+       dev-ros/rosconsole
+       dev-ros/cv_bridge
+       dev-ros/polled_camera
+       dev-ros/diagnostic_updater
+       dev-ros/camera_info_manager
+       dev-ros/moveit_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-libs/libxml2
+       sci-electronics/gazebo
+       dev-games/ogre
+       sci-libs/pcl
+       dev-libs/boost:=
+       dev-qt/qtcore:4
+       dev-qt/qtgui:4
+       dev-ros/roslib[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/gazebo_plugins/gazebo_plugins-9999.ebuild b/dev-ros/gazebo_plugins/gazebo_plugins-9999.ebuild
new file mode 100644 (file)
index 0000000..45c19f2
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-simulation/gazebo_ros_pkgs"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Robot-independent Gazebo plugins for sensors, motors and dynamic reconfigurable components"
+LICENSE="BSD Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/gazebo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/roscpp
+       dev-ros/rospy
+       dev-ros/nodelet
+       dev-ros/angles
+       dev-ros/std_srvs
+       dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+       dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/urdf
+       dev-ros/tf
+       dev-ros/tf2_ros
+       dev-ros/dynamic_reconfigure
+       dev-ros/driver_base
+       dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/trajectory_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/pcl_conversions
+       dev-ros/image_transport
+       dev-ros/rosconsole
+       dev-ros/cv_bridge
+       dev-ros/polled_camera
+       dev-ros/diagnostic_updater
+       dev-ros/camera_info_manager
+       dev-ros/moveit_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-libs/libxml2
+       sci-electronics/gazebo
+       dev-games/ogre
+       sci-libs/pcl
+       dev-libs/boost:=
+       dev-qt/qtcore:4
+       dev-qt/qtgui:4
+       dev-ros/roslib[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/gazebo_plugins/metadata.xml b/dev-ros/gazebo_plugins/metadata.xml
new file mode 100644 (file)
index 0000000..c42ea5b
--- /dev/null
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>