x11-themes/obsidian-xcursors: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Sat, 19 Oct 2019 21:56:49 +0000 (23:56 +0200)
committerDavid Seifert <soap@gentoo.org>
Sat, 19 Oct 2019 21:56:49 +0000 (23:56 +0200)
Bug: https://bugs.gentoo.org/697134
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: David Seifert <soap@gentoo.org>
x11-themes/obsidian-xcursors/obsidian-xcursors-1.0.ebuild

index e7f002283bc31ef9dd15e86c0aae30feca9fcf6d..8e5b355625e0f9ad8bdce77e16e1a5a9b56b85c9 100644 (file)
@@ -1,9 +1,10 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
 MY_PN="Obsidian"
+
 DESCRIPTION="A shiny and clean xcursor theme"
 HOMEPAGE="http://www.kde-look.org/content/show.php/Obsidian+Cursors?content=73135"
 SRC_URI="http://www.kde-look.org/CONTENT/content-files/73135-${MY_PN}.tar.bz2"
@@ -11,16 +12,12 @@ SRC_URI="http://www.kde-look.org/CONTENT/content-files/73135-${MY_PN}.tar.bz2"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="amd64 ~arm x86"
-IUSE=""
-
-RDEPEND=""
-DEPEND="${RDEPEND}"
 
 S="${WORKDIR}/${MY_PN}"
 
 src_install() {
        insinto /usr/share/cursors/xorg-x11/${MY_PN}
-       doins -r cursors || die "doins failed"
+       doins -r cursors
 }
 
 pkg_postinst() {
@@ -32,7 +29,7 @@ pkg_postinst() {
        elog "Xcursor.size: 48"
        elog
        elog "Also, to globally use this set of mouse cursors edit the file:"
-       elog "    /usr/share/cursors/xorg-x11/default/index.theme"
+       elog "    ${EROOT}/usr/share/cursors/xorg-x11/default/index.theme"
        elog "and change the line:"
        elog "    Inherits=[current setting]"
        elog "to"
@@ -40,6 +37,7 @@ pkg_postinst() {
        elog
        elog "Note this will be overruled by a user's ~/.Xdefaults file."
        elog
+
        ewarn "If you experience flickering, try setting the following line in"
        ewarn "the Device section of your xorg.conf file:"
        ewarn "    Option  \"HWCursor\"  \"false\""